death wobble and loss of power. - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old October 23rd, 2013, 04:27 PM   #1
Ajhawk
Senior Member
 
Ajhawk's Avatar
 
Join Date: 03-13-11
Location: Ionia Michigan
Posts: 346
iTrader: (1)
Mentioned: 0 Post(s)
Default death wobble and loss of power.

so my lifted 96 has a small wobble, it was terrible before i put trans fluid in it, now im having a huge loss of power, i ran diag on it, says a transmission speed sensor, im wondering if this would cause the remaining small wobble i have? im about to go check the track arm bushing and see if thats also not a cause, but would appreciate any feedback on other things it could be.
Ajhawk is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:23 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.06712 seconds with 24 queries