Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old July 8th, 2013, 07:42 AM   #1
beaterk5
Senior Member
 
beaterk5's Avatar
 
Join Date: 12-21-07
Location: dansville-48819
Posts: 1,067
iTrader: (3)
Send a message via MSN to beaterk5
Misfire/ hesitation/ stumble

96 grand with the 5.2l I'm assuming it was severely neglected. I installed a new oil pump and pickup tube it fixed my knock from no oil pressure. But it throws random misfire code, idles really rough, an stumbles bucks backfires then try's to stall. Cap rotor plugs and wires look fine. Are there any common problems with these?
beaterk5 is offline   Reply With Quote
Old July 8th, 2013, 09:03 AM   #2
ajmorell
Senior Member
 
ajmorell's Avatar
 
Join Date: 01-22-07
Location: Oshkosh, WI
Posts: 3,461
iTrader: (16)
Send a message via AIM to ajmorell
FWIW when my upstream o2 sensor shit the bed it started acting like that, this was on a 98 4.0
ajmorell is online now   Reply With Quote
Old July 9th, 2013, 09:32 PM   #3
beaterk5
Senior Member
 
beaterk5's Avatar
 
Join Date: 12-21-07
Location: dansville-48819
Posts: 1,067
iTrader: (3)
Send a message via MSN to beaterk5
Looked into it more, fuel pressure is 45psi, and up stream o2 is toggleing as it should.
beaterk5 is offline   Reply With Quote
Old July 10th, 2013, 10:07 AM   #4
firehawk
Live Action!
 
firehawk's Avatar
 
Join Date: 10-02-07
Location: Clawson, Michigan
Posts: 12,008
iTrader: (41)
Leakdown and compression test, do it.
firehawk is offline   Reply With Quote
Old July 15th, 2013, 02:58 AM   #5
beaterk5
Senior Member
 
beaterk5's Avatar
 
Join Date: 12-21-07
Location: dansville-48819
Posts: 1,067
iTrader: (3)
Send a message via MSN to beaterk5
Had low comp cyl 2 but not to low. Leak down was through the crank case. Changed the plugs went one range hotter and it went away. After that threw it a cap and rotor and it ran like new.
beaterk5 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 11:30 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.06524 seconds with 22 queries