my new fj-40 family truckster - Page 21 - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Rig Builds and Pics
GL4x4 Live! GL4x4 Casino

Rig Builds and Pics Introduce your rig or post a buildup here.

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old July 10th, 2013, 09:54 AM   #401
joescamaro67
Senior Member
 
joescamaro67's Avatar
 
Join Date: 05-23-10
Location: chesaning mi usa
Posts: 765
iTrader: (18)
Mentioned: 4 Post(s)
Default

Quote:
Originally Posted by chevotass View Post
So did the broken spring fall out when u took the pump out?
If I remember right it was under a set screw. So no It didn't just fall out.
But when I looked into it at the time it was a common problem for the 5.3 and the 6.0L
joescamaro67 is online now   Reply With Quote
Sponsored Links
Advertisement
 
Old July 10th, 2013, 10:00 AM   #402
whiterhino
I'm not old, honest...
 
whiterhino's Avatar
 
Join Date: 03-07-06
Location: Davisburg MI
Posts: 22,073
iTrader: (22)
Mentioned: 23 Post(s)
Default

Quote:
Originally Posted by CheapThrillB2 View Post
I was asking nick
Get your posts in sequence.

I thought it odd you would ask me.
__________________
GLFWDA member since 1979.
Member Southern Michigan Rock Crawlers.
whiterhino is offline   Reply With Quote
Old July 10th, 2013, 10:18 AM   #403
feva4u
LCG
 
feva4u's Avatar
 
Join Date: 04-01-07
Location: Petoskey, MI
Posts: 10,494
iTrader: (12)
Mentioned: 6 Post(s)
Default

PRV spring broke? rut rogh raggy!
__________________
My Jeep
feva4u is offline   Reply With Quote
Old July 10th, 2013, 10:55 AM   #404
JohnnyJ
Low Range Drifter
 
JohnnyJ's Avatar
 
Join Date: 11-09-05
Location: Hartland, MI
Posts: 6,340
iTrader: (38)
Mentioned: 17 Post(s)
Default

Didn't you just swap the oil pan and pickup to the LS4 pan?

Quote:
Originally Posted by Google
Hey I just wanted to pass this on to you guys. 90% of oil pressure issues Ive found on these 6.0 engines is the O-ring between the oil pump & pickup tube..They deteriorate or sometimes are partially torn from factory ..This causes low oil pressure due to air getting pulled in with the oil..
and the same talk on pirate http://www.pirate4x4.com/forum/chevy...-start-up.html
__________________
Neither Skinny Nor Pretty DEAK Racing 4517 Ultra 4 Mod Class Rig
Surviving Project Car Hell - We have all been there

Last edited by JohnnyJ; July 10th, 2013 at 10:59 AM.
JohnnyJ is offline   Reply With Quote
Old July 10th, 2013, 12:00 PM   #405
Trailrig
Hoggin'-N-Boggin'
 
Trailrig's Avatar
 
Join Date: 02-13-06
Location: Flushing, MI
Posts: 1,840
iTrader: (24)
Mentioned: 5 Post(s)
Send a message via AIM to Trailrig
Default

Thanks pirate!
Trailrig is offline   Reply With Quote
Old July 10th, 2013, 12:00 PM   #406
whiterhino
I'm not old, honest...
 
whiterhino's Avatar
 
Join Date: 03-07-06
Location: Davisburg MI
Posts: 22,073
iTrader: (22)
Mentioned: 23 Post(s)
Default

I hope that's all it is.
__________________
GLFWDA member since 1979.
Member Southern Michigan Rock Crawlers.
whiterhino is offline   Reply With Quote
Old July 10th, 2013, 12:23 PM   #407
chevotass
Senior Member
 
chevotass's Avatar
 
Join Date: 11-02-06
Location: goodrich
Posts: 6,731
iTrader: (22)
Mentioned: 22 Post(s)
Send a message via AIM to chevotass
Default

Yep i did switch pans. And it happened right after. This seal thing would make sense
chevotass is offline   Reply With Quote
Old July 10th, 2013, 12:28 PM   #408
joescamaro67
Senior Member
 
joescamaro67's Avatar
 
Join Date: 05-23-10
Location: chesaning mi usa
Posts: 765
iTrader: (18)
Mentioned: 4 Post(s)
Default

there are 3 different O Rings also for the different pickups !!
joescamaro67 is online now   Reply With Quote
Old July 10th, 2013, 12:34 PM   #409
JohnnyJ
Low Range Drifter
 
JohnnyJ's Avatar
 
Join Date: 11-09-05
Location: Hartland, MI
Posts: 6,340
iTrader: (38)
Mentioned: 17 Post(s)
Default

Here's the part number for the seal for the 2009 impala SS LS4. The same seal also comes with the pickup.

Seal, Oil pump 12584922
__________________
Neither Skinny Nor Pretty DEAK Racing 4517 Ultra 4 Mod Class Rig
Surviving Project Car Hell - We have all been there
JohnnyJ is offline   Reply With Quote
Old July 10th, 2013, 01:00 PM   #410
SHARPMACHINE
F-U-CANCER!!!
 
SHARPMACHINE's Avatar
 
Join Date: 09-29-06
Location: MONTAGUE MI (BY THE SAND BOX)
Posts: 4,521
iTrader: (25)
Mentioned: 1 Post(s)
Default

Quote:
Originally Posted by JohnnyJ View Post
Didn't you just swap the oil pan and pickup to the LS4 pan?



and the same talk on pirate http://www.pirate4x4.com/forum/chevy...-start-up.html
H'mm my 5.3 seems funnay when started after sitting. After reading the pirate link, it still seems like it would be easier to drop just the pan to replace this o-ring? Of course, that guy wanted to do a pump also. I would probably just repair the tube.
__________________
Hay, look at me... I have a signature.....



RIP FULLSIZE4LIFE
SHARPMACHINE is offline   Reply With Quote
Old July 10th, 2013, 08:21 PM   #411
chevotass
Senior Member
 
chevotass's Avatar
 
Join Date: 11-02-06
Location: goodrich
Posts: 6,731
iTrader: (22)
Mentioned: 22 Post(s)
Send a message via AIM to chevotass
Default

gonna hit the dealership for the right o-ring tomorrow. hoping and praying to the wheeling gods that's all it is.
chevotass is offline   Reply With Quote
Old July 10th, 2013, 08:25 PM   #412
jhnyquest
goof ball
 
jhnyquest's Avatar
 
Join Date: 05-26-08
Location: West Olive
Posts: 26,380
iTrader: (18)
Mentioned: 9 Post(s)
Default

Here's to Hopeing.
__________________
...
jhnyquest is offline   Reply With Quote
Old July 11th, 2013, 06:50 PM   #413
chevotass
Senior Member
 
chevotass's Avatar
 
Join Date: 11-02-06
Location: goodrich
Posts: 6,731
iTrader: (22)
Mentioned: 22 Post(s)
Send a message via AIM to chevotass
Default

Fawk yesss▀▀ssssssssssssssssssssssssssssssssssssssssss
chevotass is offline   Reply With Quote
Old July 11th, 2013, 07:22 PM   #414
dreezy
Haggard Fab
 
dreezy's Avatar
 
Join Date: 03-28-08
Location: Holland Mi
Posts: 10,254
iTrader: (7)
Mentioned: 22 Post(s)
Send a message via AIM to dreezy Send a message via MSN to dreezy
Default

O ring was a Weiner?
__________________
"you think you're precious, I think you're shit."

Quote:
Originally Posted by ScOoTeR View Post
Ryan, if I wanted any shit from you, I'd go looking for Leah's strap-on.
dreezy is offline   Reply With Quote
Old July 11th, 2013, 07:26 PM   #415
jhnyquest
goof ball
 
jhnyquest's Avatar
 
Join Date: 05-26-08
Location: West Olive
Posts: 26,380
iTrader: (18)
Mentioned: 9 Post(s)
Default

Sweet
__________________
...
jhnyquest is offline   Reply With Quote
Old July 11th, 2013, 07:40 PM   #416
JohnnyJ
Low Range Drifter
 
JohnnyJ's Avatar
 
Join Date: 11-09-05
Location: Hartland, MI
Posts: 6,340
iTrader: (38)
Mentioned: 17 Post(s)
Default

I will send you the bill.
__________________
Neither Skinny Nor Pretty DEAK Racing 4517 Ultra 4 Mod Class Rig
Surviving Project Car Hell - We have all been there
JohnnyJ is offline   Reply With Quote
Old July 11th, 2013, 09:15 PM   #417
chevotass
Senior Member
 
chevotass's Avatar
 
Join Date: 11-02-06
Location: goodrich
Posts: 6,731
iTrader: (22)
Mentioned: 22 Post(s)
Send a message via AIM to chevotass
Default

Quote:
Originally Posted by JohnnyJ View Post
I will send you the bill.
you the man JJ
chevotass is offline   Reply With Quote
Old July 11th, 2013, 09:20 PM   #418
chevotass
Senior Member
 
chevotass's Avatar
 
Join Date: 11-02-06
Location: goodrich
Posts: 6,731
iTrader: (22)
Mentioned: 22 Post(s)
Send a message via AIM to chevotass
Default

well. hit up the dealership today. $8.65 later I had a new o-ring. came home and pulled the pan and sure enough. torn up o-ring. popped the new one on. bolted everything back up. dumped in some oril. psi shot right up to 50. drove around for 30 minutes and its running great.

huge thanks to everyones input and links to save me from spending a lot more money.

now onto the next issue. the ls4 oil pan I bought off ebay is leaking. right in the middle of the pan. it must have a hair line crack or something. I can wipe the pan clean. then I slowly watch it bleed thru. its kinda creepy.

bad o ring.

chevotass is offline   Reply With Quote
Old July 11th, 2013, 10:12 PM   #419
whiterhino
I'm not old, honest...
 
whiterhino's Avatar
 
Join Date: 03-07-06
Location: Davisburg MI
Posts: 22,073
iTrader: (22)
Mentioned: 23 Post(s)
Default

Great to hear Nick. (about the o-ring, not the pan)
__________________
GLFWDA member since 1979.
Member Southern Michigan Rock Crawlers.
whiterhino is offline   Reply With Quote
Old July 11th, 2013, 11:01 PM   #420
montecarlo33
The Violator
 
montecarlo33's Avatar
 
Join Date: 08-23-07
Location: Otsego County 49735
Posts: 4,575
iTrader: (19)
Mentioned: 4 Post(s)
Default

Which o ring did you order? Stock 6.0 or the one that goes with the pan?
montecarlo33 is online now   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Rig Builds and Pics

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:16 PM.


Powered by: vBulletin, Copyright ę2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.24023 seconds with 82 queries