XJ: 96 xj injector clicking when in the ON position. And also no spark. - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old March 22nd, 2013, 07:02 PM   #1
jeeporv
Jailbait
 
jeeporv's Avatar
 
Join Date: 01-28-09
Location: Portage mi
Posts: 52
iTrader: (1)
Mentioned: 0 Post(s)
Default 96 xj injector clicking when in the ON position. And also no spark.

I've got a 96 xj. And when when I turn the key to the ON position a injector keeps clicking. I also wasn't getting spark and went through and replaced a bad ignition coil, new cap and rotor and just replaced the crank position sensor. The battery is good. I take it out of my DD and into the jeep. Pulled a few plugs. And it is getting plenty of fuel. Especially the cylinder the injector is clicking on. Help would be greatly appreciated. Thanks for the time
jeeporv is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
Tags
cps, injector clicking, no spark, no start, xj

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:35 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.08109 seconds with 24 queries