04 powerstroke - Page 2 - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old January 25th, 2013, 11:31 AM   #21
yj-woody
member
 
yj-woody's Avatar
 
Join Date: 06-20-10
Location: grand rapids mi
Posts: 320
iTrader: (4)
Mentioned: 0 Post(s)
Default

Ok I put the new turbo on. Turbo works great. No over boosting anymore. I hooked up to my trailer and put my jeep on it. Have no power towing at all. It's like I am trying to pull my jeep with a ford ranger. It's really bad.. What could this be? Put new fuel filters in. When I did the turbo and oil change.... Help please... Thanks
yj-woody is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old January 25th, 2013, 11:45 AM   #22
special k
Senior Member
 
special k's Avatar
 
Join Date: 04-14-08
Location: South Lyon 48178
Posts: 3,090
iTrader: (38)
Mentioned: 0 Post(s)
Default

Vgt solenoid only allows oil into the turbo to control vgt function. The boost pressure is read off of the map sensor on the heater box. Cracked up pipe on the passenger side if y pipe on drivers side can also create lack of power concerns and will magnify while towing as the load is there but turbo cannot be spooled with the leak. But most likely if it sat a long time the unison ring is seized
special k is offline   Reply With Quote
Old January 25th, 2013, 11:51 AM   #23
yj-woody
member
 
yj-woody's Avatar
 
Join Date: 06-20-10
Location: grand rapids mi
Posts: 320
iTrader: (4)
Mentioned: 0 Post(s)
Default

Just put a new turbo on it. The turbo works great. Nothing wrong with the turbo now. Just put the turbo on Monday and a new drain pipe. I can feel the Difference with this turbo. But still now towing power..
yj-woody is offline   Reply With Quote
Old January 25th, 2013, 12:28 PM   #24
firehawk
Live Action!
 
firehawk's Avatar
 
Join Date: 10-02-07
Location: Clawson, Michigan
Posts: 12,546
iTrader: (44)
Mentioned: 13 Post(s)
Default

Have you driven a diesel before?
firehawk is online now   Reply With Quote
Old January 25th, 2013, 12:39 PM   #25
yj-woody
member
 
yj-woody's Avatar
 
Join Date: 06-20-10
Location: grand rapids mi
Posts: 320
iTrader: (4)
Mentioned: 0 Post(s)
Default

Yes. I have. And this one has no balls. My buddy has a 03 and pulls a 30 ft gooseneck. Mine can't even pull a 18ft car trailer with a jeep on it with out dropping speed from 70 to 45 going up a small hill.
yj-woody is offline   Reply With Quote
Old January 25th, 2013, 12:42 PM   #26
firehawk
Live Action!
 
firehawk's Avatar
 
Join Date: 10-02-07
Location: Clawson, Michigan
Posts: 12,546
iTrader: (44)
Mentioned: 13 Post(s)
Default

Auto trans?

If so does it downshift?
firehawk is online now   Reply With Quote
Old January 25th, 2013, 12:44 PM   #27
yj-woody
member
 
yj-woody's Avatar
 
Join Date: 06-20-10
Location: grand rapids mi
Posts: 320
iTrader: (4)
Mentioned: 0 Post(s)
Default

Yes auto. It don't down shift. Just dogs down..
yj-woody is offline   Reply With Quote
Old January 25th, 2013, 12:48 PM   #28
firehawk
Live Action!
 
firehawk's Avatar
 
Join Date: 10-02-07
Location: Clawson, Michigan
Posts: 12,546
iTrader: (44)
Mentioned: 13 Post(s)
Default

Quote:
Originally Posted by yj-woody View Post
Yes auto. It don't down shift. Just dogs down..
That could be your problem, the trans.


Have you tried to manually downshift it?
firehawk is online now   Reply With Quote
Old January 25th, 2013, 12:49 PM   #29
Tacker
Senior Member
 
Tacker's Avatar
 
Join Date: 06-15-06
Location: Fruitport / Muskegon
Posts: 10,445
iTrader: (25)
Mentioned: 6 Post(s)
Default

Probably blew a head gasket with all of the overboost problems....
Tacker is offline   Reply With Quote
Old January 25th, 2013, 12:50 PM   #30
yj-woody
member
 
yj-woody's Avatar
 
Join Date: 06-20-10
Location: grand rapids mi
Posts: 320
iTrader: (4)
Mentioned: 0 Post(s)
Default

I will have to try that tonight.. Thanks
yj-woody is offline   Reply With Quote
Old January 25th, 2013, 12:51 PM   #31
yj-woody
member
 
yj-woody's Avatar
 
Join Date: 06-20-10
Location: grand rapids mi
Posts: 320
iTrader: (4)
Mentioned: 0 Post(s)
Default

Thanks Terry I really wanted to hear that...
yj-woody is offline   Reply With Quote
Old January 25th, 2013, 12:56 PM   #32
tvandyck7
OlllllllO
 
tvandyck7's Avatar
 
Join Date: 04-22-12
Location: Birch Run
Posts: 65
iTrader: (1)
Mentioned: 0 Post(s)
Default

Try unplugging the egr valve and leaving unplugged. If it is an 04, it won't throw a CEL. I drove my 04 for 2 years with it unplugged without a problem. Mine had no balls pulling up hills until I unplugged that stupid valve.
tvandyck7 is offline   Reply With Quote
Old January 25th, 2013, 01:00 PM   #33
yj-woody
member
 
yj-woody's Avatar
 
Join Date: 06-20-10
Location: grand rapids mi
Posts: 320
iTrader: (4)
Mentioned: 0 Post(s)
Default

I did up plug it last night. It made it better. But still.. Did you every find out why your was a dog?
yj-woody is offline   Reply With Quote
Old January 25th, 2013, 01:06 PM   #34
tvandyck7
OlllllllO
 
tvandyck7's Avatar
 
Join Date: 04-22-12
Location: Birch Run
Posts: 65
iTrader: (1)
Mentioned: 0 Post(s)
Default

Once I unplugged the egr valve it came back to life.
tvandyck7 is offline   Reply With Quote
Old January 25th, 2013, 01:07 PM   #35
tvandyck7
OlllllllO
 
tvandyck7's Avatar
 
Join Date: 04-22-12
Location: Birch Run
Posts: 65
iTrader: (1)
Mentioned: 0 Post(s)
Default

I had a straight pipe and programmer on mine and rarely ever drove it in stock form.
tvandyck7 is offline   Reply With Quote
Old January 25th, 2013, 01:10 PM   #36
tvandyck7
OlllllllO
 
tvandyck7's Avatar
 
Join Date: 04-22-12
Location: Birch Run
Posts: 65
iTrader: (1)
Mentioned: 0 Post(s)
Default

Look at some of my posts from a few years back on the dieselstop.com. I have some pretty extensive write ups on there. I am tvandyck7 on there too.
tvandyck7 is offline   Reply With Quote
Old January 25th, 2013, 03:54 PM   #37
yj-woody
member
 
yj-woody's Avatar
 
Join Date: 06-20-10
Location: grand rapids mi
Posts: 320
iTrader: (4)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by tvandyck7 View Post
Look at some of my posts from a few years back on the dieselstop.com. I have some pretty extensive write ups on there. I am tvandyck7 on there too.
Ok i will have to check you out on there.. Thanks
yj-woody is offline   Reply With Quote
Old February 21st, 2013, 10:02 PM   #38
special k
Senior Member
 
special k's Avatar
 
Join Date: 04-14-08
Location: South Lyon 48178
Posts: 3,090
iTrader: (38)
Mentioned: 0 Post(s)
Default

i know it's a pretty stupid question, but is the air filter clean? don't go by the filter minder but actually by the front side of the filter. also could be a lack of fuel volume under load. the only way to truly check that is with the otc gauge that will allow you to simulate wide open throttle.
special k is offline   Reply With Quote
Old June 28th, 2013, 05:35 PM   #39
BigBird
Duck Shootin' Wheelerer!!
 
BigBird's Avatar
 
Join Date: 07-17-08
Location: Soo, Ontario
Posts: 5,322
iTrader: (8)
Mentioned: 11 Post(s)
Default

Where did you get to with this??? Curious...
__________________
Cheap Thrills Off Road
BigBird is offline   Reply With Quote
Old June 28th, 2013, 05:57 PM   #40
CheapThrillB2
FAWK YEAH!!
 
CheapThrillB2's Avatar
 
Join Date: 09-06-06
Location: Middleville, MI
Posts: 31,299
iTrader: (61)
Mentioned: 10 Post(s)
Default

He traded it in on a new truck .
CheapThrillB2 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:17 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.20619 seconds with 81 queries