Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old December 23rd, 2012, 01:42 PM   #1
s.hembree
Senior Member
 
s.hembree's Avatar
 
Join Date: 03-16-07
Location: Grand Rapids, MI
Posts: 1,400
iTrader: (4)
Mentioned: 0 Post(s)
Default 03 GMC Envoy help...

2003 GMC Envoy. Owner starts it, starts driving down the road and realizes the cluster is lit up but none of the gauges are functioning. He pulls over and shuts it off. Tries to restart and it will not crank. Battery is good. Checked fuses etc. I did some testing and found the pcm is receiving the crank signal and putting out the request to crank voltage. I don't believe the starter enable is making connection in the pcm. I have also observed that the radio lights up but does not function, power windows and locks are not working, as well as the dome light not coming on with the door switch. It's almost like it's stuck in the power saving mode during crank. I've looked at the common connections and grounds and they all appear to be ok. After studying the wiring diagrams that I have access to I can't seem to find anything that all of these items have in common other than the pcm itself, and I'm leaning toward that being the problem. Any thoughts or ideas?
s.hembree is online now   Reply With Quote
Old December 23rd, 2012, 05:23 PM   #2
bdd1469
bdd
 
bdd1469's Avatar
 
Join Date: 04-12-10
Location: alto mi
Posts: 2,063
iTrader: (1)
Mentioned: 0 Post(s)
Send a message via Yahoo to bdd1469
Default

It doesnt have a remote starter does it? If it does unhook it, throw it away, and enjoy your day. Wish I could more help.
bdd1469 is offline   Reply With Quote
Old December 23rd, 2012, 05:34 PM   #3
GREASYHANDS
wabbit season
 
GREASYHANDS's Avatar
 
Join Date: 03-16-09
Location: Ravenna
Posts: 12,461
iTrader: (28)
Mentioned: 11 Post(s)
Default

Ignition switches are a pretty common failure
__________________
Quote:
Originally Posted by RookieMT View Post
sorry I don't work on fords I park on top of them!
Bare Bones Offroad
RIP FS4L
Pavement sucks
Meow
GREASYHANDS is online now   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:52 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.06703 seconds with 18 queries