94 7.3 idi maxi fuse 11 - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old November 5th, 2012, 10:06 PM   #1
heavy74chevy
Member
 
heavy74chevy's Avatar
 
Join Date: 12-21-09
Location: Davisgurg Mi
Posts: 74
iTrader: (0)
Mentioned: 0 Post(s)
Default 94 7.3 idi maxi fuse 11

I have a 94 f350 idi turbo. I started my truck up at work as usual, everything worked as it should. Im cruisin down the road and about 20 minutes into my 30 min drive the truck just shut off. I didnt loose power to anything else, all lights still work radio and heater. Starter still cranks the motor over it just wont fire. In the fuse box under the hood maxi fuse 11 is blown. I rigged my fuel shut off solenoid with a wire to my battery and it starts and runs, but my wait to start light doesnt come on and when i replace the fuse it pops again. Is the glow plug relay on the same fuse as the fuel shut off solenoid and if my relay went bad could it cause the fuse to blow. I think the only reason it started with the wire is because it was still warm and didnt need the glow plugs. My guess is the relay but any help is appreciated.
heavy74chevy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old November 6th, 2012, 12:14 PM   #2
not sure
no wait! my name is joe
 
not sure's Avatar
 
Join Date: 09-25-07
Location: Sturgis, Michigan
Posts: 220
iTrader: (4)
Mentioned: 0 Post(s)
Default

I pulled a diagram and the fuses are labeled in letters not numbers so i dont know what circuit your talking about
not sure is offline   Reply With Quote
Old November 7th, 2012, 09:02 AM   #3
heavy74chevy
Member
 
heavy74chevy's Avatar
 
Join Date: 12-21-09
Location: Davisgurg Mi
Posts: 74
iTrader: (0)
Mentioned: 0 Post(s)
Default

I found a diagram online and they use letters but on the under side of the panel cover they use numbers. I figured it out thought, it controls the fuel shut off solenoid the cold idle solenoid and the glow plug relay. I found a bare wire in the harness that was grounding out and blowing my fuse which in turn was shuting off my fuel at the ip. Taped it up and shes all better.
heavy74chevy is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:51 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.08767 seconds with 30 queries