Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old September 30th, 2012, 08:58 PM   #1
ttrailtj
looking 4 #8 Jeep
 
ttrailtj's Avatar
 
Join Date: 03-12-06
Location: Flint,mi,
Posts: 125
iTrader: (2)
Mentioned: 0 Post(s)
Send a message via Yahoo to ttrailtj
Default 97 4.0 hard starting

this is posted in gen. tech too. I have a 97 XJ runs great, but after it been ran and off for a few mins hard to start, cant keep it at idle, but get it rolling on the road is fine again, and its gwtting worse daily ??
ttrailtj is offline   Reply With Quote
Old October 1st, 2012, 10:23 PM   #2
Mr. Pink
Jeep-a-holic
 
Mr. Pink's Avatar
 
Join Date: 04-29-10
Location: Capac, Michigan
Posts: 231
iTrader: (1)
Mentioned: 0 Post(s)
Default

Check the fuel check valve, mine has teh same issue but has never given me issues of not starting, it will run rough for about a min but clears up.
Mr. Pink is offline   Reply With Quote
Old October 1st, 2012, 10:26 PM   #3
Schoemann
-----------------------
 
Schoemann's Avatar
 
Join Date: 05-29-12
Location: Grand Blanc, Mi
Posts: 1,713
iTrader: (5)
Mentioned: 1 Post(s)
Default

Does it crank over fine and just rough at idle?
Schoemann is online now   Reply With Quote
Old October 2nd, 2012, 05:50 AM   #4
ttrailtj
looking 4 #8 Jeep
 
ttrailtj's Avatar
 
Join Date: 03-12-06
Location: Flint,mi,
Posts: 125
iTrader: (2)
Mentioned: 0 Post(s)
Send a message via Yahoo to ttrailtj
Default

yea it starts, spits,sputters, you let off the gas it will stall you need to keep feathering the gas to keep it running till you get back on the road then its fine and will idle at stop lights fine its just at restart
ttrailtj is offline   Reply With Quote
Old October 2nd, 2012, 06:05 AM   #5
curbdog17
.
 
curbdog17's Avatar
 
Join Date: 08-10-08
Location: 49415
Posts: 31,728
iTrader: (23)
Mentioned: 17 Post(s)
Default

Quote:
Originally Posted by ttrailtj View Post
yea it starts, spits,sputters, you let off the gas it will stall you need to keep feathering the gas to keep it running till you get back on the road then its fine and will idle at stop lights fine its just at restart
TPS is going bad?
__________________
.
curbdog17 is offline   Reply With Quote
Old October 2nd, 2012, 07:14 AM   #6
hightech
Crawl 101
 
hightech's Avatar
 
Join Date: 04-19-10
Location: Davision Mich,
Posts: 543
iTrader: (0)
Mentioned: 0 Post(s)
Default

Tps
hightech is offline   Reply With Quote
Old October 2nd, 2012, 07:01 PM   #7
ttrailtj
looking 4 #8 Jeep
 
ttrailtj's Avatar
 
Join Date: 03-12-06
Location: Flint,mi,
Posts: 125
iTrader: (2)
Mentioned: 0 Post(s)
Send a message via Yahoo to ttrailtj
Default

cool I plan to take the TB off and take off the tps and give them a good cleaning and see what that does, Thanks everyone
ttrailtj is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 04:58 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.09616 seconds with 26 queries