mercury 115 intermit water pumping - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > Other Stuff > Boats, canoes, and rubber ducks
GL4x4 Live! GL4x4 Casino

Boats, canoes, and rubber ducks Chat about things that float

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old July 9th, 2012, 02:00 PM   #1
jeepinjz
Senior Member
 
jeepinjz's Avatar
 
Join Date: 07-18-06
Location: Southgate MI (48195)
Posts: 3,669
iTrader: (72)
Mentioned: 1 Post(s)
Default mercury 115 intermit water pumping

I have a 1996 115 hp mercury had a pumping problem out the squirter replaced impeller still the same took apart blew it all out ran water through everything was good for 2 days then did the same thing again then put it back in the water without doing anything good for that whole day and stopped again any ideals what I'm I missing thanks
jeepinjz is online now   Reply With Quote
Sponsored Links
Advertisement
 
Old August 1st, 2012, 03:16 PM   #2
hosejockey4506
Visiting Admin
 
hosejockey4506's Avatar
 
Join Date: 11-04-05
Location: fenton
Posts: 8,808
iTrader: (43)
Mentioned: 5 Post(s)
Default

have you checked the poppit valve
__________________
one of Michigans 99% er club.
hosejockey4506 is offline   Reply With Quote
Old August 1st, 2012, 03:53 PM   #3
Bones
skillicous
 
Bones's Avatar
 
Join Date: 11-06-05
Location: Dearborn Heights, MI
Posts: 11,499
iTrader: (37)
Mentioned: 3 Post(s)
Send a message via AIM to Bones
Default

tstats?
__________________
Inviscid Motorsports

Special Thanks and Recommendations to;
Motorcity Machines
Ironman Offroad
Branik Motorsports
Maxxis Tires

Raceline Wheels
PAC Racing Springs
Joint Clutch and Gear
Bones is offline   Reply With Quote
Old August 2nd, 2012, 09:23 PM   #4
jeepinjz
Senior Member
 
jeepinjz's Avatar
 
Join Date: 07-18-06
Location: Southgate MI (48195)
Posts: 3,669
iTrader: (72)
Mentioned: 1 Post(s)
Default

Took and had it fixed at the marine thanks for the replys
jeepinjz is online now   Reply With Quote
Old September 23rd, 2012, 10:18 PM   #5
captiancobble
lost in translation
 
captiancobble's Avatar
 
Join Date: 12-20-07
Location: muskegon
Posts: 234
iTrader: (7)
Mentioned: 0 Post(s)
Default

What did they find wrong?
captiancobble is online now   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > Other Stuff > Boats, canoes, and rubber ducks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:38 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.10597 seconds with 36 queries