Need some help with my buddies Dodge stratus....no compression all cylinder - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > General 4x4 Stuff > The Pub
GL4x4 Live! GL4x4 Casino

The Pub A friendly forum where everybody is nice, and will answer any questions you have about life.

greatlakes4x4.com is the premier All Forum on the internet. Registered Users do not see the above ads.
Search
Closed Thread
 
Thread Tools Search this Thread
Old March 26th, 2012, 01:11 AM   #1
barry1me
Just another day
 
barry1me's Avatar
 
Join Date: 06-09-06
Location: Howell, MI
Posts: 2,912
iTrader: (9)
Mentioned: 0 Post(s)
Default Need some help with my buddies Dodge stratus....no compression all cylinder

So my buddy has a Dodge stratus that is not running. We checked the compression on all 6 cylinders and they all show zero. We pulled the intake, and manifold off and we can see that the when you turn over the engine the intake valves are all open or maybe move just a tiny amount. When we pulled off the valve cover we can see the cams moving and the rockers going up and down. Im not to engine savy so I dont really know what any of this means. To give you a little background on this car, it has a vortech supercharger on it for the last 30k miles on it. He was cruising down the highway and the drivebelt blew and wrapped around the crank taking out the timing cover, and crank position sensor. He put a new timing belt on, crank position sensor, timing cover, and drive belt. Once he got it all back together he noticed it wouldnt start, no compression.
barry1me is offline  
Sponsored Links
Advertisement
 
Old March 26th, 2012, 04:18 AM   #2
booblinker
Trailer Trash
 
booblinker's Avatar
 
Join Date: 10-29-06
Location: Leonard, mi
Posts: 9,833
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to booblinker
Default

2.7? If yes timing tensioner plugged, motor go boom, usually not rebuildable.
__________________
-2001 Tahoe original 5.3 4x4 only 435k
-Down to 2 three wheelers
-1985 V65 Magna
-1978 F100
-1973 CT70(soon to have a 125 motor)
booblinker is offline  
Old March 26th, 2012, 04:45 AM   #3
barry1me
Just another day
 
barry1me's Avatar
 
Join Date: 06-09-06
Location: Howell, MI
Posts: 2,912
iTrader: (9)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by booblinker View Post
2.7? If yes timing tensioner plugged, motor go boom, usually not rebuildable.
I think its a 3.0l mitsubishi motor
barry1me is offline  
Old March 26th, 2012, 05:24 AM   #4
mean_greenEXJAY
YJ now
 
mean_greenEXJAY's Avatar
 
Join Date: 02-05-07
Location: Vicksburg, MI
Posts: 1,382
iTrader: (5)
Mentioned: 0 Post(s)
Default

I hope no one would ever put a supercharger on a 2.7
mean_greenEXJAY is offline  
Old March 26th, 2012, 06:31 AM   #5
ckupq
Kitten I'm gonna eat you!
 
ckupq's Avatar
 
Join Date: 11-07-05
Location: Cedar Rapids, IA 52402
Posts: 3,393
iTrader: (6)
Mentioned: 0 Post(s)
Default

Only the 2 doors had the 3.0L

If he's got the 4 door 2.7L, either go pull one from a junk yard or throw the car away.

I'm trying to get rid of mine before I get to where your buddy is at. Its a great motor, till it blows.
ckupq is offline  
Old March 26th, 2012, 06:33 AM   #6
Immortal
NO RELIGION WAT!
 
Immortal's Avatar
 
Join Date: 11-09-05
Location: In my garage
Posts: 25,434
iTrader: (46)
Mentioned: 52 Post(s)
Default

We need a general tech forum!
One of you minions make this happen!
Immortal is online now  
Old March 26th, 2012, 06:40 AM   #7
barry1me
Just another day
 
barry1me's Avatar
 
Join Date: 06-09-06
Location: Howell, MI
Posts: 2,912
iTrader: (9)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by ckupq View Post
Only the 2 doors had the 3.0L

If he's got the 4 door 2.7L, either go pull one from a junk yard or throw the car away.

I'm trying to get rid of mine before I get to where your buddy is at. Its a great motor, till it blows.
ITs the 2 door model so it has to be the 3.0L. So what do you think is wrong with the motor?
barry1me is offline  
Old March 26th, 2012, 06:43 AM   #8
Immortal
NO RELIGION WAT!
 
Immortal's Avatar
 
Join Date: 11-09-05
Location: In my garage
Posts: 25,434
iTrader: (46)
Mentioned: 52 Post(s)
Default

Just go buy a new crate motor and drive another 200k
Immortal is online now  
Old March 26th, 2012, 06:45 AM   #9
barry1me
Just another day
 
barry1me's Avatar
 
Join Date: 06-09-06
Location: Howell, MI
Posts: 2,912
iTrader: (9)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by Immortal View Post
Just go buy a new crate motor and drive another 200k
so motor is junk? It only has 90k miles on it.
barry1me is offline  
Old March 26th, 2012, 07:25 AM   #10
ckupq
Kitten I'm gonna eat you!
 
ckupq's Avatar
 
Join Date: 11-07-05
Location: Cedar Rapids, IA 52402
Posts: 3,393
iTrader: (6)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by barry1me View Post
ITs the 2 door model so it has to be the 3.0L. So what do you think is wrong with the motor?
Its an interference motor, all the valves are bent from hitting the pistons. If you're lucky they might have a top end kit for the motor now...
ckupq is offline  
Old March 26th, 2012, 09:22 AM   #11
kickstand
sHaMoNe!
 
kickstand's Avatar
 
Join Date: 09-20-06
Location: fenton
Posts: 30,895
iTrader: (46)
Mentioned: 24 Post(s)
Default

Quote:
Originally Posted by barry1me View Post
ITs the 2 door model so it has to be the 3.0L. So what do you think is wrong with the motor?
It doesn't have any compression....duh.
kickstand is online now  
Old March 26th, 2012, 09:46 AM   #12
wilesin
Senior Member
 
wilesin's Avatar
 
Join Date: 04-16-09
Location: Iowa
Posts: 1,817
iTrader: (0)
Mentioned: 2 Post(s)
Default

Quote:
Originally Posted by ckupq View Post
Its an interference motor, all the valves are bent from hitting the pistons. If you're lucky they might have a top end kit for the motor now...
This. Engine is junk, repair or replace.
wilesin is offline  
Old March 26th, 2012, 09:57 AM   #13
Sandals
Fucking Zen as Shit
 
Sandals's Avatar
 
Join Date: 11-05-05
Location: Lindenhurst, IL
Posts: 15,314
iTrader: (7)
Mentioned: 1 Post(s)
Default

Quote:
Originally Posted by Immortal View Post
We need a general tech forum!
One of you minions make this happen!
It really is a damn shame we dont have one of those.



Oh wait WE DO!!!!

maybe since people don't like to use the right forums we should just combine everything into one forum. Everything in one place.
Sandals is offline  
Closed Thread
Great Lakes 4x4. The largest offroad forum in the Midwest > General 4x4 Stuff > The Pub

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:32 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.13958 seconds with 60 queries