Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old February 17th, 2012, 11:58 PM   #1
chevyk10
FORD / GM
 
chevyk10's Avatar
 
Join Date: 11-21-09
Location: Howell
Posts: 883
iTrader: (0)
Mentioned: 1 Post(s)
Default Auto Locking Hubs Stuck in 4x4

I know they're junk to begin with but I don't really have the money right now to get manual hubs and a conversion kit. Anyway I have a 95 F150 floor shift 4x4... last week when I went to put it in 4x4 HI the hubs sounded like they were clicking, and now whenever I put the truck in 4x4 I can't get it back in 2wd unless I really fight with it (usually keep shifting between 2 / 4 wheel multiple times while giving it gas and making a hard turn). Sometimes it will come back in 2wd no problem while 80% of the time it wants to be stubborn. Anyone ever have this problem? The rest of the 4wd system is in great shape and has been regularly maintained so I'm 99.9% sure it's the hubs.
chevyk10 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 09:30 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.05066 seconds with 14 queries