2001 Wrangler Sahara Engine Misfire (Lights On) - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old January 2nd, 2012, 08:25 PM   #1
Jetson
Member
 
Jetson's Avatar
 
Join Date: 07-23-11
Location: Canton
Posts: 85
iTrader: (1)
Mentioned: 0 Post(s)
Default 2001 Wrangler Sahara Engine Misfire (Lights On)

Hey Guys Not so thrilled.. After vacation (7 days stopped) started my Jeep wrangler from DTW and drove back the engine sort of lost some power and RPM started to get stuck around 2000 and would not run past 55 mph. The check engine lights popped on. Took it to a local mechanic shop the guy checked for codes and said he could not find anything and the computer (module) had an error.. was sort of confused and dint have the 100 bucks to shed on dealer to just tell me what was going on. Took it to autozone today, the guy ran the codes and said my fuel injector was probably dirty and recommended a cleaner and said my engine had some misfires and I needed to get a engine tune-up. Well the othe code that good old O2 sensor going bad going bad is already known to me

My Questions:
1. How much does it usually cost for a engine tune-up? Should I do it at the dealership or?
2. Should I take autozone codes or the advice of the first mechanic who suggested the computer problem ?

Thanks in advance
Jetson is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old January 2nd, 2012, 08:29 PM   #2
Dylan
Senior Member
 
Dylan's Avatar
 
Join Date: 08-24-06
Location: K-zoo
Posts: 1,125
iTrader: (7)
Mentioned: 0 Post(s)
Default

turn key on , off, on, off, on

read the codes from the odometer.

Report codes back here
Dylan is offline   Reply With Quote
Old January 2nd, 2012, 08:39 PM   #3
buttercr125
I work out
 
buttercr125's Avatar
 
Join Date: 02-10-09
Location: Fenton, mi
Posts: 2,587
iTrader: (26)
Mentioned: 0 Post(s)
Default

PM me if you need diagnostic help. I have access to alldata, identifix, iatn etc.....

I am real good with driveability issues.
buttercr125 is offline   Reply With Quote
Old January 2nd, 2012, 08:44 PM   #4
Jetson
Member
 
Jetson's Avatar
 
Join Date: 07-23-11
Location: Canton
Posts: 85
iTrader: (1)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by Dylan View Post
turn key on , off, on, off, on

read the codes from the odometer.

Report codes back here
Hi Dylan, Just did it. Here are the 8 codes that popped up.

P0201
P0205
P0135
P0300
P0303
P0304
P0171
P0138
Jetson is offline   Reply With Quote
Old January 2nd, 2012, 08:45 PM   #5
Jetson
Member
 
Jetson's Avatar
 
Join Date: 07-23-11
Location: Canton
Posts: 85
iTrader: (1)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by buttercr125 View Post
PM me if you need diagnostic help. I have access to alldata, identifix, iatn etc.....

I am real good with driveability issues.
Sure dude.. will do if I need help.. thanks.
Jetson is offline   Reply With Quote
Old January 2nd, 2012, 08:53 PM   #6
Dylan
Senior Member
 
Dylan's Avatar
 
Join Date: 08-24-06
Location: K-zoo
Posts: 1,125
iTrader: (7)
Mentioned: 0 Post(s)
Default

P0201 cyl 1 injector circuit (check 12v+ as injector 1, check connector, check pulse if you have test led)

P0205 cyl 2 injector circuit (same as 1)

P0135 O2 sensor crcuit. Check 12v+ at O2 sensor (same 12v to injectors also)

P0300 random misfire (caused by injector failure stated above)

P0303 miss cyl 3 (same as above)

P0304 miss cyl 4 (same as above)

P0171 system to lean (caused by injectors)

P0138 O2 bank 1 sensor 2 voltage high (probably same as lean)

I think you have 2 or more injectors not firing causing the miss and the rest of the codes.

Clear the codes by disconnecting the pcm plugs behind the battery for a min or so. Check the codes again after and see if any are back right away. Then run the motor and see if anything comes back. You can have anything from bad connectors to bad injectors. My guess is bad injectors.
Dylan is offline   Reply With Quote
Old January 2nd, 2012, 08:56 PM   #7
jbsjunk
Wheelies
 
jbsjunk's Avatar
 
Join Date: 03-01-08
Location: Almost Allendale Mi
Posts: 16,084
iTrader: (36)
Mentioned: 16 Post(s)
Default

Quote:
Originally Posted by Jetson View Post
P0201 P0202 Injector Circuit Malfunction - Cylinder 2
P0205 P0205 Injector Circuit Malfunction - Cylinder 5
P0135 P0135 02 Sensor Heater Circuit Malfunction (Bank 1 Sensor 1)
P0300 P0300 Random/Multiple Cylinder Misfire Detected
P0303 P0303 Cylinder 3 Misfire Detected
P0304 P0304 Cylinder 4 Misfire Detected
P0171 P0171 System too Lean (Bank 1)
P0138 P0138 02 Sensor Circuit High Voltage (Bank I Sensor 2)
http://www.obd-codes.com/trouble_codes/
jbsjunk is offline   Reply With Quote
Old January 2nd, 2012, 09:14 PM   #8
Jetson
Member
 
Jetson's Avatar
 
Join Date: 07-23-11
Location: Canton
Posts: 85
iTrader: (1)
Mentioned: 0 Post(s)
Default

Thanks Dylan and jbsjunk.. Will check for those when the snow dries out.
Jetson is offline   Reply With Quote
Old February 5th, 2012, 06:38 PM   #9
Jetson
Member
 
Jetson's Avatar
 
Join Date: 07-23-11
Location: Canton
Posts: 85
iTrader: (1)
Mentioned: 0 Post(s)
Default

I wanted to leave a message here as a knowledge base.. Haven't seen the fix to the issue in any other Jeep forum. First of all the drive-ability issue happens only in cold temperatures (~ 20's - low 30's), the reason for this is driving when engine is cold. What I did was took it to a store and had them clear all the misfire codes out to test it. Then bought it home and did a through engine flush/oil change. Started warming the engine for 10 or more odd minutes before driving in the morning.. she is perfect now ..just raves .. I still need to fix u-joints in the front which I will come back to the greatest resource for help the Great Lakes 4*4 forum
Jetson is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Jeep Tech
Tags
2001, jeep, sahara, wrangler

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:35 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.21976 seconds with 48 queries