Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Toyota Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old January 6th, 2012, 12:26 PM   #1
isuzutruggy?
Kreepy Krawlerz Off Road
 
isuzutruggy?'s Avatar
 
Join Date: 10-15-09
Location: traverse city michigan
Posts: 644
iTrader: (4)
Angry 22r wont stay running?

22r idles fine, but when I try to go down the road it acts like its running out of gas? It has a full tank. I changed the fuel filter on the frame rail, put some dry gas in the tank, it has a fairly new fuel pump. What else could it be?
isuzutruggy? is offline   Reply With Quote
Old January 6th, 2012, 01:42 PM   #2
974x4Taco
Flex Is OverRated
 
974x4Taco's Avatar
 
Join Date: 11-19-06
Location: Battle Creek
Posts: 1,915
iTrader: (7)
Tank pickup?
974x4Taco is online now   Reply With Quote
Old January 6th, 2012, 01:55 PM   #3
isuzutruggy?
Kreepy Krawlerz Off Road
 
isuzutruggy?'s Avatar
 
Join Date: 10-15-09
Location: traverse city michigan
Posts: 644
iTrader: (4)
Quote:
Originally Posted by 974x4Taco View Post
Tank pickup?
That's new too
isuzutruggy? is offline   Reply With Quote
Old January 6th, 2012, 02:04 PM   #4
osteologation
Everyday I'm Shufflin'
 
osteologation's Avatar
 
Join Date: 03-31-08
Location: Caro, MI
Posts: 1,709
iTrader: (7)
ignition timing? or isn't the 22r carby? accelerator pump? and jsut because a fuel pump is new doesn't mean it hasn't gone bad.
osteologation is offline   Reply With Quote
Old January 6th, 2012, 02:17 PM   #5
isuzutruggy?
Kreepy Krawlerz Off Road
 
isuzutruggy?'s Avatar
 
Join Date: 10-15-09
Location: traverse city michigan
Posts: 644
iTrader: (4)
Quote:
Originally Posted by osteologation View Post
ignition timing? or isn't the 22r carby? accelerator pump? and jsut because a fuel pump is new doesn't mean it hasn't gone bad.
Yes its carb'd, typically when the fuel pump goes bad they just stop working. Its a mechanical one
isuzutruggy? is offline   Reply With Quote
Old January 6th, 2012, 03:11 PM   #6
Haggar
Covered in mud...
 
Haggar's Avatar
 
Join Date: 11-06-05
Location: Oxford, MI
Posts: 17,400
iTrader: (52)
If its a fuel delivery problem, try splicing in a low pressure fue pressure gauge in right before the carb. l

It could also be something in the carb itself, squirts enough from the idle circuits but not putting out enough when you get on it. Float setting wrong.

Check timing as well. Check vacuum lines.
Haggar is online now   Reply With Quote
Old January 6th, 2012, 05:15 PM   #7
isuzutruggy?
Kreepy Krawlerz Off Road
 
isuzutruggy?'s Avatar
 
Join Date: 10-15-09
Location: traverse city michigan
Posts: 644
iTrader: (4)
Quote:
Originally Posted by Haggar View Post
If its a fuel delivery problem, try splicing in a low pressure fue pressure gauge in right before the carb. l

It could also be something in the carb itself, squirts enough from the idle circuits but not putting out enough when you get on it. Float setting wrong.

Check timing as well. Check vacuum lines.
Tore the carb apart, had a little bit of dirt in the bowl, what do you mean by float setting wrong? Its not sticking or anything. Someone told me I had to big of tires on stock gears and that might be why its not running right? I have 35's on stock gears. I didnt think that would matter.
isuzutruggy? is offline   Reply With Quote
Old January 6th, 2012, 05:36 PM   #8
solid95yota
"the wonder truck"
 
solid95yota's Avatar
 
Join Date: 07-26-08
Location: new boston
Posts: 703
iTrader: (5)
no just cuz you have bigger tires isnt going to make it die. just be very very slow
solid95yota is offline   Reply With Quote
Old January 6th, 2012, 06:03 PM   #9
isuzutruggy?
Kreepy Krawlerz Off Road
 
isuzutruggy?'s Avatar
 
Join Date: 10-15-09
Location: traverse city michigan
Posts: 644
iTrader: (4)
Quote:
Originally Posted by solid95yota View Post
no just cuz you have bigger tires isnt going to make it die. just be very very slow
thats what i thought!
isuzutruggy? is offline   Reply With Quote
Old January 11th, 2012, 06:44 PM   #10
isuzutruggy?
Kreepy Krawlerz Off Road
 
isuzutruggy?'s Avatar
 
Join Date: 10-15-09
Location: traverse city michigan
Posts: 644
iTrader: (4)
put an electric fuel pump on it and now it runs like a champ
isuzutruggy? is offline   Reply With Quote
Old January 12th, 2012, 02:45 AM   #11
alaska907
Newbie
 
Join Date: 01-01-12
Location: fairbanks alaska
Posts: 18
iTrader: (0)
what do your spark plugs look like are they black of are they a nice brown
alaska907 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Toyota Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:53 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.11131 seconds with 34 queries