2003 gmc 2500 speedo/tach inop - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old January 4th, 2012, 09:27 PM   #1
special k
Senior Member
 
special k's Avatar
 
Join Date: 04-14-08
Location: South Lyon 48178
Posts: 3,090
iTrader: (38)
Mentioned: 0 Post(s)
Exclamation 2003 gmc 2500 speedo/tach inop

i have a 2003 GMC 2500hd, 6.0L vortec. speedo does not work at all, and tach will work when you first start the truck then will peg to 0, but if revved it will come up but not to an appropriate RPM. i found some shit online saying the stepper motors in the cluster wear out and can cause these symptoms, anyone have any knowledge or experience with this?
special k is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:25 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.05732 seconds with 24 queries