Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old January 2nd, 2012, 06:19 AM   #21
AFRd_CJ5
Senior Member
 
AFRd_CJ5's Avatar
 
Join Date: 03-26-07
Location: Carson City
Posts: 681
iTrader: (1)
I've ran a Proform electric fan for a few years now (I believe 5) and never had an issue. Single SPAL 16" fan with a shroud.
Never had any overheating issues at the dunes, and I'm either crawling around at 5MPH, or drag racing.
AFRd_CJ5 is offline   Reply With Quote
Old January 2nd, 2012, 09:23 AM   #22
Plato2k5
In Da Faaaaaace!!!
 
Plato2k5's Avatar
 
Join Date: 12-25-05
Location: WMU Kzoo Mi / Livonia, MI
Posts: 5,392
iTrader: (17)
Send a message via AIM to Plato2k5
I thin its a combination of an undersized radiator, lack of a shroud that covers the entire backside of the radiator, and lack of shielding on the side of the radiator that forces air through the front and not around.

I hope once the new rad is in it will all be cured.
Plato2k5 is offline   Reply With Quote
Old January 2nd, 2012, 09:45 AM   #23
mudbillyredneck
Senior Member
 
mudbillyredneck's Avatar
 
Join Date: 01-17-08
Location: Lapeer, MI
Posts: 4,730
iTrader: (132)
Perhaps a better thermostate or try some "water wetter" additive , maybe your just a few degree's from being able to enjoy the rig as it is currently set up ?.

Sometimes it's the little things that can make a big differance


Best of luck on your fine tuneing
mudbillyredneck is offline   Reply With Quote
Old January 2nd, 2012, 10:15 AM   #24
skife
Senior Member
 
skife's Avatar
 
Join Date: 02-12-07
Location: cedar springs mi
Posts: 5,051
iTrader: (5)
Send a message via AIM to skife Send a message via MSN to skife
try putting in a 195 thermostat
skife is offline   Reply With Quote
Old January 2nd, 2012, 10:40 AM   #25
Plato2k5
In Da Faaaaaace!!!
 
Plato2k5's Avatar
 
Join Date: 12-25-05
Location: WMU Kzoo Mi / Livonia, MI
Posts: 5,392
iTrader: (17)
Send a message via AIM to Plato2k5
did all of that before. This is nothing new really. Its been an issue for 5 or 6 years what I did the V8 conversion. I learned to deal with it since I was not wanting to drop the coin for a new setup...plus other parts needed attention lol. I'm tired of having to shut it down and sit for a few mins every so often while at silver lake. Water weter and the stuff royal purple sells didn't do a thing.

My engine is just putting out more HP than the radiator will cool.
Plato2k5 is offline   Reply With Quote
Old January 2nd, 2012, 11:25 AM   #26
AFRd_CJ5
Senior Member
 
AFRd_CJ5's Avatar
 
Join Date: 03-26-07
Location: Carson City
Posts: 681
iTrader: (1)
I wanna see pictures of how you got the bottom radiator hose attached!
AFRd_CJ5 is offline   Reply With Quote
Old January 2nd, 2012, 02:17 PM   #27
Plato2k5
In Da Faaaaaace!!!
 
Plato2k5's Avatar
 
Join Date: 12-25-05
Location: WMU Kzoo Mi / Livonia, MI
Posts: 5,392
iTrader: (17)
Send a message via AIM to Plato2k5
Hahaha......it is afro engineering at its best. Ill post pics later.
Plato2k5 is offline   Reply With Quote
Old January 3rd, 2012, 11:13 AM   #28
Plato2k5
In Da Faaaaaace!!!
 
Plato2k5's Avatar
 
Join Date: 12-25-05
Location: WMU Kzoo Mi / Livonia, MI
Posts: 5,392
iTrader: (17)
Send a message via AIM to Plato2k5
Plato2k5 is offline   Reply With Quote
Old January 4th, 2012, 05:59 AM   #29
AFRd_CJ5
Senior Member
 
AFRd_CJ5's Avatar
 
Join Date: 03-26-07
Location: Carson City
Posts: 681
iTrader: (1)
Well, I gotta say, that's something I've never seen before. Not sure how else you'd do that though with outlets on the opposite sides!
AFRd_CJ5 is offline   Reply With Quote
Old January 4th, 2012, 05:44 PM   #30
Plato2k5
In Da Faaaaaace!!!
 
Plato2k5's Avatar
 
Join Date: 12-25-05
Location: WMU Kzoo Mi / Livonia, MI
Posts: 5,392
iTrader: (17)
Send a message via AIM to Plato2k5
its been like that for a long while .... fugly for sure! I really don't know why I bought the rad with op. outlet/inlet. Its been so long but i'm sure there was a reason behind it!!!!
Plato2k5 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > General Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 05:49 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.10821 seconds with 32 queries