wipers in my 91 chevy only works on high - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old November 29th, 2011, 05:43 PM   #1
73chevytruck
73chevytruck
 
73chevytruck's Avatar
 
Join Date: 10-01-11
Location: owosso,mi
Posts: 59
iTrader: (0)
Mentioned: 0 Post(s)
Default wipers in my 91 chevy only works on high

The wipers in my 91 chevy truck only works on high. No intermediant speeds just on high the squirters don't work neither any ideas ??
73chevytruck is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old November 29th, 2011, 07:02 PM   #2
ChevyRacer1981
Throw'in turtles........
 
ChevyRacer1981's Avatar
 
Join Date: 05-07-08
Location: Sagnasty / MI
Posts: 2,361
iTrader: (32)
Mentioned: 0 Post(s)
Default

Curcuit board on the whiper motor is screwed. I got the same thing only mine stop whenever they feel like it when I turn them off. Changed it and good to go.
ChevyRacer1981 is offline   Reply With Quote
Old November 29th, 2011, 09:08 PM   #3
bdd1469
bdd
 
bdd1469's Avatar
 
Join Date: 04-12-10
Location: alto mi
Posts: 2,103
iTrader: (1)
Mentioned: 0 Post(s)
Send a message via Yahoo to bdd1469
Default

Quote:
Originally Posted by ChevyRacer1981 View Post
Curcuit board on the whiper motor is screwed. I got the same thing only mine stop whenever they feel like it when I turn them off. Changed it and good to go.
Thats a common problem.
bdd1469 is offline   Reply With Quote
Old November 30th, 2011, 08:50 AM   #4
73chevytruck
73chevytruck
 
73chevytruck's Avatar
 
Join Date: 10-01-11
Location: owosso,mi
Posts: 59
iTrader: (0)
Mentioned: 0 Post(s)
Default

I've tried a different circuit board. Tried a differnt wiper motor. And just tried a different wiper switch and it still only worked on high. But the switch was used. The washer squirters don't work neither.
73chevytruck is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:36 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.11566 seconds with 33 queries