1991 S10 Blazer 4 Door Build "Blazed" - Page 2 - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Rig Builds and Pics
GL4x4 Live! GL4x4 Casino

Rig Builds and Pics Introduce your rig or post a buildup here.

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old January 7th, 2011, 01:40 PM   #21
GMKLR50
Broke wheeler
 
GMKLR50's Avatar
 
Join Date: 10-13-10
Location: White Lake, MI ( Detroit side of state)
Posts: 1,158
iTrader: (5)
Mentioned: 0 Post(s)
Default

i havent taken it anywhere, ive had it for about 5 months and durring that time i ended up moving and had to put a few of my plans for it off, so im just starting on fixing some of the little things it needs. EFI took it to silver lake this summer I believe.
GMKLR50 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old January 7th, 2011, 06:42 PM   #22
efi355
Newbie
 
Join Date: 08-11-10
Location: farmington hills mi
Posts: 26
iTrader: (0)
Mentioned: 0 Post(s)
Default

Ha yea I used to run the shit outa it at the dunes. Yes I built it no my parents don't have a dime into it lol. And hope you got all the trail fixes/ petty shit fixed. Sorry bout the fuel pump... It was running like shit the last day of the last dune trip but only when the pump was hot and ran fine during normal use so I figured that pump still had some life left in it. O well. And the prop block definitly needs to be mounted... It broke the line off hence the expoxy holding it together lol. I noticed it was starting to leak a lil bit when u bought it. But yea I think u still got an amazing deal on it lol good luck
efi355 is offline   Reply With Quote
Old January 9th, 2011, 05:38 PM   #23
GMKLR50
Broke wheeler
 
GMKLR50's Avatar
 
Join Date: 10-13-10
Location: White Lake, MI ( Detroit side of state)
Posts: 1,158
iTrader: (5)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by efi355 View Post
Ha yea I used to run the shit outa it at the dunes. Yes I built it no my parents don't have a dime into it lol. And hope you got all the trail fixes/ petty shit fixed. Sorry bout the fuel pump... It was running like shit the last day of the last dune trip but only when the pump was hot and ran fine during normal use so I figured that pump still had some life left in it. O well. And the prop block definitly needs to be mounted... It broke the line off hence the expoxy holding it together lol. I noticed it was starting to leak a lil bit when u bought it. But yea I think u still got an amazing deal on it lol good luck
the pump seems ok it have just poped a fuse once...maybe that will happend once it get hot again I dont know, Ive only driven it a few times but one trip was about 60 miles as i took it out to my new house in White lake from Redford. what is this your saying about the prop block, i didnt notice anything but I havent looked.. i have run in to a few other things, like the heater core leaks only when you run the heat and beat on it a bit. there seems to be fluids leaking (very little) from all covers (diff, valve, trans pan, oil pan) all easy fixes i need to change all the fluids anyways. I havent found anything to be worried about just little things that most people would probally live with I could but its givening my little things to work on over the winter when im bored.
GMKLR50 is offline   Reply With Quote
Old January 9th, 2011, 09:36 PM   #24
efi355
Newbie
 
Join Date: 08-11-10
Location: farmington hills mi
Posts: 26
iTrader: (0)
Mentioned: 0 Post(s)
Default

Hmmm the heater core is complete news to me lol. It used to leak water onto the floor but I found I missed a grommet on the firewall.. Maybe I was wrong. The h cores kinda old maybe 2005 (I kno its not old but compared to everything else) iyea most of the fluids leak a lil bit... I had to back onto a log to change a tire n it fucked up the diff cover on the back a lil bit. I never really cared lol. Does the oil pan leak still? Lol if you didn't figured it out the front axle traveled far enoung to smack the oil pan n grind a hole in the inspection cover grab the o2 and the trans line etc lol... I'd definitly make a set of bump stops if you plan on jumping it hard. Worked great except for the last one (prolly four feet of air to flat) but I definitly used all 14" of travel lol but for what it is it actually did quite good. Godammit I wish I still had it... Seeing your avatar makes me sad lol
efi355 is offline   Reply With Quote
Old January 9th, 2011, 09:47 PM   #25
efi355
Newbie
 
Join Date: 08-11-10
Location: farmington hills mi
Posts: 26
iTrader: (0)
Mentioned: 0 Post(s)
Default

O and upon rereading ur post look at the back of the prop block like the side that faces the fire wall. There gray shit around the fitting. Its the back brake like so its no biggie. I wouldn't bother trying to fix it to save you the trouble... The tapped hole is fucked n its got a male flare it there. If I rememeber right I drilled n tapped it over size but since its flare it no work good so I shoved for glue in there (this is all the dunes had to offer for a means of a fix) I'd buy a new prop block if it bother you or leaks anymore. O and I do believe its missing a collecter gasket on one side... It started to leak pretty bad and apparently none of the auto parts places carry 2.5 gaskets around the dunes (seriously NONE we drove all over the dam place) so I ended up filing the flanges flat n it sealed up good lol.
efi355 is offline   Reply With Quote
Old January 10th, 2011, 08:23 AM   #26
GMKLR50
Broke wheeler
 
GMKLR50's Avatar
 
Join Date: 10-13-10
Location: White Lake, MI ( Detroit side of state)
Posts: 1,158
iTrader: (5)
Mentioned: 0 Post(s)
Default

Im throwing on a new oil pan and got some diff guards to fix the leaks. I havent noticed the exhaust leaking either, im just going to leave the fix for now its just exhaust....as for the heater core I am told that the vacuum valves go bad from lack of use. I got to pull it apart to find out where its leaking from exactly...I just dont want to do you know any tricks to not pulling the dash?
GMKLR50 is offline   Reply With Quote
Old January 10th, 2011, 03:47 PM   #27
whopeasy
Newbie
 
whopeasy's Avatar
 
Join Date: 02-06-10
Location: zeeland mi
Posts: 9
iTrader: (0)
Mentioned: 0 Post(s)
Send a message via Yahoo to whopeasy
Default

wow way to hijack someones page
whopeasy is offline   Reply With Quote
Old June 6th, 2011, 12:46 AM   #28
XTREMERIDER87
Newbie
 
XTREMERIDER87's Avatar
 
Join Date: 12-03-10
Location: GREENWOOD TWP,MI
Posts: 6
iTrader: (0)
Mentioned: 0 Post(s)
Send a message via AIM to XTREMERIDER87 Send a message via Yahoo to XTREMERIDER87
Default

what length and lift springs did you use on your blazer PLAYRPACO?
GMKLR50,What kind of set-up did you use to lift your blazer and sized tires?
XTREMERIDER87 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Rig Builds and Pics

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:21 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.21203 seconds with 45 queries