Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old May 27th, 2011, 06:30 AM   #1
heavy74chevy
Member
 
heavy74chevy's Avatar
 
Join Date: 12-21-09
Location: Davisgurg Mi
Posts: 73
iTrader: (0)
Mentioned: 0 Post(s)
Default 93 f350 7.3 idi rough idle white smoke and stalling

I have a 93 7.3 idi ran great my oil cooler was leaking oil into my anti freeze so i swapped it out. It ran great for afew days then one morning i started it, idled fine, as soon as i took off it chuged and stalled. It started up again and ran great. Afew days later it chugged again for afew secounds then ran great for afew more days. I started it last night it idled fine i took off and made it about 20 feet it started chugging and died, it would start but was ideling very rough and then would die. This morning same thing rough idel, it was blowin enough white smoke to clear any intersection then it died again, any ideas what it could be? It has new glow plugs, fuel filter and oil filter. Im lost any help would be greatly appreciated
heavy74chevy is offline   Reply With Quote
Old May 27th, 2011, 07:43 AM   #2
osteologation
Everyday I'm Shufflin'
 
osteologation's Avatar
 
Join Date: 03-31-08
Location: Caro, MI
Posts: 1,709
iTrader: (7)
Mentioned: 0 Post(s)
Default

Generally big white clouds is antifreeze. Bad head or intake gasket. That would be my first guess.
osteologation is offline   Reply With Quote
Old May 27th, 2011, 09:59 AM   #3
ultimatehellhound
Senior Member
 
Join Date: 12-07-10
Location: Hampshire, IL
Posts: 184
iTrader: (1)
Mentioned: 0 Post(s)
Default

Check your lift pump. Mine died yesterday, time for the Holley blue and another filter to go on.
ultimatehellhound is offline   Reply With Quote
Old May 27th, 2011, 04:34 PM   #4
chevyk10
FORD / GM
 
chevyk10's Avatar
 
Join Date: 11-21-09
Location: Howell
Posts: 883
iTrader: (0)
Mentioned: 1 Post(s)
Default

Check your exhaust bearings.
chevyk10 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 10:46 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.11298 seconds with 20 queries