94 LT1 question? - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old January 31st, 2011, 11:48 AM   #1
skife
Senior Member
 
skife's Avatar
 
Join Date: 02-12-07
Location: cedar springs mi
Posts: 5,129
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to skife Send a message via MSN to skife
Default 94 LT1 question?

Bought a 90 K5 blazer with a 94 lt1 in it. truck has been sitting for a few years and the header collectors have rotted off, it runs like crap mid range, it screams at WOT and idles nice.

Could it be something to do with the O2 sensors?
skife is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old January 31st, 2011, 12:02 PM   #2
in2deep
Hole tester
 
Join Date: 05-06-10
Location: muskegon,mi
Posts: 1,280
iTrader: (3)
Mentioned: 1 Post(s)
Default

yes at wot it does not use 02 it goes off the preprogramed fuel map in the ecm
in2deep is offline   Reply With Quote
Old January 31st, 2011, 01:15 PM   #3
toyota h8r
Senior Member
 
toyota h8r's Avatar
 
Join Date: 03-27-10
Location: sylvania
Posts: 367
iTrader: (1)
Mentioned: 0 Post(s)
Default

just part throttle issues? sounds like the opti spark is dumping on you
toyota h8r is offline   Reply With Quote
Old January 31st, 2011, 01:27 PM   #4
skife
Senior Member
 
skife's Avatar
 
Join Date: 02-12-07
Location: cedar springs mi
Posts: 5,129
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to skife Send a message via MSN to skife
Default

Quote:
Originally Posted by toyota h8r View Post
just part throttle issues? sounds like the opti spark is dumping on you
opti was new when it was parked, was parked like 2 years ago though, outside, not on concrete. can the opti be cleaned or does it need to be replaced?
skife is offline   Reply With Quote
Old January 31st, 2011, 01:33 PM   #5
skife
Senior Member
 
skife's Avatar
 
Join Date: 02-12-07
Location: cedar springs mi
Posts: 5,129
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to skife Send a message via MSN to skife
Default

also, should i be running premium in this?
skife is offline   Reply With Quote
Old February 1st, 2011, 11:16 AM   #6
toyota h8r
Senior Member
 
toyota h8r's Avatar
 
Join Date: 03-27-10
Location: sylvania
Posts: 367
iTrader: (1)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by skife View Post
also, should i be running premium in this?
aluminum headed lt1? id run premium.....the iron one you could maybe get away with 89......hell i ran 87 in my 95 t/a once......it ran but just like crap though the rpm ranges


and no ya cant clean the opti-spark......once the sensor starts acting up its done. i replaced a lot of opti's and mainly were mid-range"popping/sputtering" or wouldnt get above 4000rpm and act like its on the rev limiter
toyota h8r is offline   Reply With Quote
Old February 1st, 2011, 11:33 AM   #7
TopGunn
Burried
 
TopGunn's Avatar
 
Join Date: 01-24-10
Location: Livonia
Posts: 248
iTrader: (1)
Mentioned: 0 Post(s)
Send a message via AIM to TopGunn Send a message via MSN to TopGunn
Default

Quote:
Originally Posted by toyota h8r View Post

and no ya cant clean the opti-spark......once the sensor starts acting up its done.
Ahh the opti spark setup such a great design placed in A great spot! Lol
TopGunn is offline   Reply With Quote
Old February 1st, 2011, 06:48 PM   #8
mprmn08
Senior Member
 
mprmn08's Avatar
 
Join Date: 01-08-09
Location: grandville, mi
Posts: 252
iTrader: (0)
Mentioned: 0 Post(s)
Default

Quote:
Originally Posted by toyota h8r View Post
aluminum headed lt1? id run premium.....the iron one you could maybe get away with 89......hell i ran 87 in my 95 t/a once......it ran but just like crap though the rpm ranges
are the alum. headed ones alot higher compression or something? if there the same you can get away with less octane then a cast headed motor so why premium on alum and 87 would be fine on cast?

my buddys got a 95 t/a with an lt1 and he can run 89 just fine with the stock computer in. he can run 87 from some places but some places have shitty fuel and it wont run right. so i would 89.. 93 octane on a stock ecm is just a waste of money in my opinion. you dont necessarily get better performance from higher octane fuel unless you need it. high octane burns slower so it wont perform as well if you dont need it.
mprmn08 is offline   Reply With Quote
Old February 2nd, 2011, 07:52 PM   #9
skife
Senior Member
 
skife's Avatar
 
Join Date: 02-12-07
Location: cedar springs mi
Posts: 5,129
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to skife Send a message via MSN to skife
Default

Quote:
Originally Posted by mprmn08 View Post
are the alum. headed ones alot higher compression or something? if there the same you can get away with less octane then a cast headed motor so why premium on alum and 87 would be fine on cast?

my buddys got a 95 t/a with an lt1 and he can run 89 just fine with the stock computer in. he can run 87 from some places but some places have shitty fuel and it wont run right. so i would 89.. 93 octane on a stock ecm is just a waste of money in my opinion. you dont necessarily get better performance from higher octane fuel unless you need it. high octane burns slower so it wont perform as well if you dont need it.
ECU is out of a '94 camaro, Don't know how stock it is.
skife is offline   Reply With Quote
Old February 2nd, 2011, 09:24 PM   #10
mprmn08
Senior Member
 
mprmn08's Avatar
 
Join Date: 01-08-09
Location: grandville, mi
Posts: 252
iTrader: (0)
Mentioned: 0 Post(s)
Default

just a thought but what about a knock sensor? pulling timing out at part throttle and makin it run like crap?
mprmn08 is offline   Reply With Quote
Old February 3rd, 2011, 10:01 AM   #11
skife
Senior Member
 
skife's Avatar
 
Join Date: 02-12-07
Location: cedar springs mi
Posts: 5,129
iTrader: (5)
Mentioned: 0 Post(s)
Send a message via AIM to skife Send a message via MSN to skife
Default

Quote:
Originally Posted by mprmn08 View Post
just a thought but what about a knock sensor? pulling timing out at part throttle and makin it run like crap?
It could be that, but the headers have rotted off at the collector from sitting so long, the O2 sensors are in the exhuast behind the collector, so its automatically getting a lean single so it is getting more fuel than it should. its got a half tank full of 87 octane in it (could be causing spark knock and retarding the timing)

thats my theroy
skife is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:57 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.18597 seconds with 54 queries