99 dodge 2500 - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old February 10th, 2010, 11:33 PM   #1
boggin-machine
Senior Member
 
boggin-machine's Avatar
 
Join Date: 01-11-06
Location: bay city
Posts: 11,653
iTrader: (31)
Mentioned: 0 Post(s)
Default 99 dodge 2500

today while plowing i noticed that my dash lights went out. the radio lights still work but i lost power to my lights in the cluster and my 3 guages on the pillar. everything seems to work on the dash though. i checked all my fuses i could think to check. the illumantion bullb was fine. we also checked the cluster A fuse. cluster B fuse we fine as well. its driving me nuts as i do most of my driving early morning or later in the day now and watch my guages regularly. so i continued to plow and everything was fine but the lights still didnt work.

i just went out to take my plow off and plug the truck in for the night. i hop in it and i notice i left the running lights on. but there wasnt any running lights ON the exterior of the truck. only on the switch it appears. i have brake lights on both sides but no running lights on the rear of the truck or on the front as well.

we checked any and all fuses that would relate to it and went through the trouble tree for it on MITCHELL ON DEMAND. i am kind of stumped.

im thinking the switch. if i have time in the next day or so im going to pull the switch and test it.
boggin-machine is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old February 11th, 2010, 07:52 AM   #2
SHARPMACHINE
F-U-CANCER!!!
 
SHARPMACHINE's Avatar
 
Join Date: 09-29-06
Location: MONTAGUE MI (BY THE SAND BOX)
Posts: 4,532
iTrader: (25)
Mentioned: 1 Post(s)
Default

Yep, it is the switch. Also, when installing the new switch, drill a couple holes in the heat duct so air circulates in there to keep the new one from going bad. This is a mod off from DTR that I have done to keep mine working.
__________________
Hay, look at me... I have a signature.....



RIP FULLSIZE4LIFE
SHARPMACHINE is offline   Reply With Quote
Old February 11th, 2010, 07:28 PM   #3
boggin-machine
Senior Member
 
boggin-machine's Avatar
 
Join Date: 01-11-06
Location: bay city
Posts: 11,653
iTrader: (31)
Mentioned: 0 Post(s)
Default

fixed it today.
boggin-machine is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Dodge Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:01 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.08381 seconds with 30 queries