need a little help - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Suzuki Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old September 14th, 2009, 09:12 PM   #1
bdavid
Senior Member
 
bdavid's Avatar
 
Join Date: 03-03-08
Location: detroit metro
Posts: 637
iTrader: (8)
Mentioned: 0 Post(s)
Default need a little help

I just set a deal on a 88zuk with some pretty good mods. It needs some tlc but runs. Is there anyone in the down river area that wants to give a hand on getting some things fixed?

1. the brakes are not working. The brake pedal goes to the floor and it wants to stall when you press the pedal.

2. need a set of doors both are bent pretty bad and dont close.

3. I need to install the GM alternator.( I have the alternator and wiring kit)

The biggest thing I need help with is the brakes I dont know why it is doing this. what I do know is it has new a new master cylinder calipers and wheel cylinders. any help would be great.

There is more things but this is the most important to fix right now..
bdavid is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old September 17th, 2009, 03:41 PM   #2
A4X4SPIT
Senior Member
 
A4X4SPIT's Avatar
 
Join Date: 09-10-06
Location: Bear lake Mi
Posts: 446
iTrader: (1)
Mentioned: 0 Post(s)
Default

when you bleed the brakes does fluid come out (with engine off)and or do wheels stop spinning(when on stands) when brake pedal is depressedId start with basic stuff 1st are shoes on rear in good shape &adjusted up are the ft pads good if not this will require more pedal movement mabee to much ive had brakes too worn to work right ..once ya get it so all wheels stop w/pedal whenyou spin them if it still wants to stall when you step on the brakes its probably a bad booster unhook &plug the vacuum line & see if the brakes work w/no vacuum assistif the engine dosent stall its most likley the booster
A4X4SPIT is offline   Reply With Quote
Old September 17th, 2009, 03:50 PM   #3
scottie
American Leyland??
 
scottie's Avatar
 
Join Date: 11-05-05
Location: not in Georgia
Posts: 8,511
iTrader: (2)
Mentioned: 2 Post(s)
Send a message via AIM to scottie
Default

If your current alternator is good, don't bother doing the GM swap until that one is toast.
scottie is online now   Reply With Quote
Old December 17th, 2009, 08:36 PM   #4
irideablackbike
Specialized Epic
 
Join Date: 11-29-06
Location: Ann Arbor
Posts: 104
iTrader: (0)
Mentioned: 0 Post(s)
Default

stock carb or weber? if its the stock carb you have a vacuum issue...if its the weber, you still have a vacuum issue but its easier to fix.
irideablackbike is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Suzuki Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:51 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.10993 seconds with 33 queries