Exploder help - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old January 23rd, 2009, 01:41 PM   #1
dakotaguy1
DODGE POWER!
 
dakotaguy1's Avatar
 
Join Date: 07-08-07
Location: White Lake,MI
Posts: 1,773
iTrader: (17)
Mentioned: 0 Post(s)
Send a message via AIM to dakotaguy1
Default Exploder help

buddy has a 96 explorer sport 4x4 and has this really annoying squeek or chirping sound from the front end. it only does it when your moving soon as you stop it stops. just put on new brakes, wheels bearings, and tie rod ends. any ideas what it might be?
dakotaguy1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old January 23rd, 2009, 02:03 PM   #2
CheapThrillB2
FAWK YEAH!!
 
CheapThrillB2's Avatar
 
Join Date: 09-06-06
Location: Middleville, MI
Posts: 31,528
iTrader: (62)
Mentioned: 12 Post(s)
Default

dry ball joint socket
CheapThrillB2 is offline   Reply With Quote
Old January 23rd, 2009, 02:08 PM   #3
fsumotorhead
N8KVB
 
fsumotorhead's Avatar
 
Join Date: 10-24-06
Location: Flat Rock, MI
Posts: 4,202
iTrader: (34)
Mentioned: 0 Post(s)
Default

x2

or a bent dust plate if you were just in there servicing the truck
fsumotorhead is offline   Reply With Quote
Old January 23rd, 2009, 02:29 PM   #4
dakotaguy1
DODGE POWER!
 
dakotaguy1's Avatar
 
Join Date: 07-08-07
Location: White Lake,MI
Posts: 1,773
iTrader: (17)
Mentioned: 0 Post(s)
Send a message via AIM to dakotaguy1
Default

so it might be a dry ball joint?
dakotaguy1 is offline   Reply With Quote
Old January 23rd, 2009, 08:29 PM   #5
04 EDGE
Floor Shift Maddness!
 
04 EDGE's Avatar
 
Join Date: 01-08-08
Location: Westland Mi
Posts: 1,372
iTrader: (7)
Mentioned: 0 Post(s)
Send a message via AIM to 04 EDGE
Default

dry socket, tie rod or ball joint, maybe a u joint also
04 EDGE is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:16 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.10753 seconds with 36 queries