6.2 diesel problems - Great Lakes 4x4. The largest offroad forum in the Midwest

Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech
GL4x4 Live! GL4x4 Casino

greatlakes4x4.com is the premier Great Lakes 4x4 Forum on the internet. Registered Users do not see the above ads.
Search
Reply
 
Thread Tools Search this Thread
Old August 11th, 2008, 06:55 PM   #1
stoneagemaxx
Newbie
 
Join Date: 01-04-07
Location: New Hudson
Posts: 8
iTrader: (0)
Mentioned: 0 Post(s)
Send a message via AIM to stoneagemaxx
Default 6.2 diesel problems

last wendsday driving home from work i noticed the burb was runnin a little ruff at idel, within a 1/4 mile it started loseing power rapidly, it took over a mile to reach 40mph then i hit a downhill and it went up to 55, got it home, thought possibly a fuel filter, replaced it and started it up, it started, reved up just fine so we took it for a ride, seemed a little better, went about 11 miles stopped for about 3 min and let it idel, put it in reverse and it died, started it back up and it had no power even worse than before, with some persuesion and manual shifting it would rev up most of the time but not all, so i get it on the e'way and it dident want to go above 50, then dropped to 45, getting off the exit it died again started right back up made it a half mile to the light, ideld though the light with a lil throttle, put it in 1st and it just sluggishly moved dident even get past 5mph, pulled into the fuel station put about 10 gallons in it (cheapest its been in a long time) took a quick look under the hood and under the truck and found nothing, started it back up and put it in first and it took off, reved out fine as long as i manually shifted it went about 2.5 miles and started losing power again, pulling into my drive it lost all power again, i shut it down,pulled into low range and waited 10 min fired up and drove it up the drive to the garage, kinda stumped now, going to check fuel pressure while cranking, but is there any way to check while running, dosent look so to me, sorry about the long post but its my DD and i kinda need it up and running, it is alot worse under load, oh and i fired it up today and the normal puff's of blue/grey smoke dident clear up more so on the right side any help is appreciated. thanks
stoneagemaxx is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old August 11th, 2008, 06:57 PM   #2
xj97sport
atv rider
 
xj97sport's Avatar
 
Join Date: 01-08-08
Location: south west
Posts: 6,557
iTrader: (20)
Mentioned: 0 Post(s)
Default

fuel filter changed latley?
xj97sport is offline   Reply With Quote
Old August 11th, 2008, 07:10 PM   #3
stoneagemaxx
Newbie
 
Join Date: 01-04-07
Location: New Hudson
Posts: 8
iTrader: (0)
Mentioned: 0 Post(s)
Send a message via AIM to stoneagemaxx
Default

yes first thing done after repair of return fule leak(lose clamp)
stoneagemaxx is offline   Reply With Quote
Old August 12th, 2008, 12:42 AM   #4
blownexploder94
Todd
 
blownexploder94's Avatar
 
Join Date: 11-22-07
Location: South Lyon
Posts: 1,074
iTrader: (6)
Mentioned: 0 Post(s)
Default

when he stated above that the smoke didn;t clear up and was on the right side, he meant on the right bank of the motor, it has dual exhaust
blownexploder94 is offline   Reply With Quote
Old August 12th, 2008, 06:15 AM   #5
dodger889
Senior Member
 
dodger889's Avatar
 
Join Date: 03-12-08
Location: north of ann arbor, mi
Posts: 1,109
iTrader: (8)
Mentioned: 1 Post(s)
Default

MMm sounds like water is getting in the cylinders to me.
dodger889 is offline   Reply With Quote
Old August 12th, 2008, 03:21 PM   #6
stoneagemaxx
Newbie
 
Join Date: 01-04-07
Location: New Hudson
Posts: 8
iTrader: (0)
Mentioned: 0 Post(s)
Send a message via AIM to stoneagemaxx
Default

dident really smell like coolent, both sides had more smoke than norman and for longer but the left bank cleared up faster
stoneagemaxx is offline   Reply With Quote
Old August 12th, 2008, 10:40 PM   #7
blownexploder94
Todd
 
blownexploder94's Avatar
 
Join Date: 11-22-07
Location: South Lyon
Posts: 1,074
iTrader: (6)
Mentioned: 0 Post(s)
Default

It just smells like raw unburnt fuel for the most part....... smokes like a cold deisel on a very cold morning but right side never clears up
blownexploder94 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Chevy Tech

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:08 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Page generated in 0.16421 seconds with 45 queries