Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > Great Lakes 4x4 Marketplace > Parts for sale
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old April 21st, 2006, 04:49 PM   #1
4x4inAllDay
Dodge Father-Ram Daughter
 
4x4inAllDay's Avatar
 
Join Date: 11-09-05
Location: Utica, Mi
Posts: 240
iTrader: (0)
Send a message via AIM to 4x4inAllDay
5.9 360 approx 155xxx miles

its a 1997 motor, magnum
before this happened, didnt tick,knock, burn anything, smoke... it ran like perfect.. an older guy from this board owned the truck and didnt beat on it.. still have reciepts for oil changes and what not to prove it... like it matters now

was in my 97 ram took the ram to the mounds got water in it and thoguht i killed the motor

so i pulled the motor and replaced it with another one...

now i took this one apart and its just sitting here...

got the block, heads, intake, balencer, crank, cam

it ran when i took it apart but had ticking in the lower end, appears to have shot the crank bearings and possibly cam bearings as well. other than that upon tearing it apart found no bent rods or valve springs or anything, still looked in decent shape

I know its still definitly useable to the right person, i was gonna rebuild it and build it up... but i want to put money into somethign else right now real bad....
4x4inAllDay is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > Great Lakes 4x4 Marketplace > Parts for sale
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:16 AM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.07433 seconds with 14 queries