Go Back   Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
GL4x4 Live! GL4x4 Casino







Search
Reply
 
Thread Tools
Old April 9th, 2008, 07:47 AM   #1
Bronco351
Powered by Ford
 
Bronco351's Avatar
 
Join Date: 09-26-07
Location: Garden City, MI; Pensacola, FL
Posts: 2,014
iTrader: (8)
Mentioned: 0 Post(s)
Send a message via Yahoo to Bronco351
Default Oil Pressure/ Electrical ?????

alright, on my bronco (5.8L) the oil pressure gauge needle sits on the red line by the L when the engine is on. I have driven it ~50 miles with it like that. Shouldn't the motor have seized up by now if i really had no oil pressure?
Also, my motor does not have the oil cooler adapter that goes from the ring above the filter to the water pump. Could that mess up the oil pressure sensor somehow? is there anyway to test the oil pressure?
Bronco351 is offline   Reply With Quote
Old April 9th, 2008, 07:59 AM   #2
broncobuddha
Starting over
 
broncobuddha's Avatar
 
Join Date: 09-13-07
Location: kalamazoo mi
Posts: 859
iTrader: (2)
Mentioned: 0 Post(s)
Send a message via AIM to broncobuddha
Default

put on a mechanical oil pressure gauge, the stock ones are not really accurate and tend to get worse as they age
broncobuddha is offline   Reply With Quote
Old April 9th, 2008, 08:05 AM   #3
Bronco351
Powered by Ford
 
Bronco351's Avatar
 
Join Date: 09-26-07
Location: Garden City, MI; Pensacola, FL
Posts: 2,014
iTrader: (8)
Mentioned: 0 Post(s)
Send a message via Yahoo to Bronco351
Default

Quote:
Originally Posted by broncobuddha View Post
put on a mechanical oil pressure gauge, the stock ones are not really accurate and tend to get worse as they age
That kinda what i was thinking was that the sensor might be shot. Cause if i really had no oil pressure my engine might have already seized up.
Bronco351 is offline   Reply With Quote
Old April 9th, 2008, 08:26 AM   #4
03hemisilver
Pres MI Dodgetruckworld
 
03hemisilver's Avatar
 
Join Date: 04-22-07
Location: Northville, MI
Posts: 1,748
iTrader: (30)
Mentioned: 0 Post(s)
Default

The sending unit on the block is only a $5-10 part, easy fix until you can get to a mechanical gage. It would most likely be knocking like heck or siezed by now if it was serious.
__________________
80 CJ frame, YJ body, 304 cid, 4" lift, 35"s, 4.10's, locked, 8K winch, garage queen
2012 F150 4x4 Lariat Supercrew Ecoboost
03hemisilver is offline   Reply With Quote
Old April 9th, 2008, 08:44 AM   #5
Plato2k5
In Da Faaaaaace!!!
 
Plato2k5's Avatar
 
Join Date: 12-25-05
Location: WMU Kzoo Mi / Livonia, MI
Posts: 5,416
iTrader: (17)
Mentioned: 0 Post(s)
Send a message via AIM to Plato2k5
Default

you would hear lifter tick before anything as oil won't be getting to the top.

buy a mech. gauge from the parts store for around $10.
Plato2k5 is offline   Reply With Quote
Old April 9th, 2008, 08:50 AM   #6
Bronco351
Powered by Ford
 
Bronco351's Avatar
 
Join Date: 09-26-07
Location: Garden City, MI; Pensacola, FL
Posts: 2,014
iTrader: (8)
Mentioned: 0 Post(s)
Send a message via Yahoo to Bronco351
Default

alright.
Approx how long could a motor go with no pressure?
Bronco351 is offline   Reply With Quote
Old April 9th, 2008, 10:32 AM   #7
Cartman
Can't lose with 42s
 
Cartman's Avatar
 
Join Date: 08-17-06
Location: Williamsburg, MI
Posts: 1,029
iTrader: (6)
Mentioned: 0 Post(s)
Default

Lifters would start tapping like a son of a bitch almost immediately after not having any oil...You WOULD know.
Cartman is offline   Reply With Quote
Old April 9th, 2008, 01:28 PM   #8
broncobuddha
Starting over
 
broncobuddha's Avatar
 
Join Date: 09-13-07
Location: kalamazoo mi
Posts: 859
iTrader: (2)
Mentioned: 0 Post(s)
Send a message via AIM to broncobuddha
Default

if you put on 50 miles and it still runs good you have oil pressure
broncobuddha is offline   Reply With Quote
Old April 10th, 2008, 08:36 AM   #9
Bronco351
Powered by Ford
 
Bronco351's Avatar
 
Join Date: 09-26-07
Location: Garden City, MI; Pensacola, FL
Posts: 2,014
iTrader: (8)
Mentioned: 0 Post(s)
Send a message via Yahoo to Bronco351
Default

Yesterday it began leaving oil puddles when i parked it, and the engine was making some klunking noises it sounded like.
Bronco351 is offline   Reply With Quote
Old April 10th, 2008, 11:52 AM   #10
caveman
Club Pen15
 
caveman's Avatar
 
Join Date: 11-09-06
Location: Sturgis MI.
Posts: 2,381
iTrader: (13)
Mentioned: 0 Post(s)
Default

stupid question but is the oil low?
caveman is offline   Reply With Quote
Old April 11th, 2008, 08:16 AM   #11
Bronco351
Powered by Ford
 
Bronco351's Avatar
 
Join Date: 09-26-07
Location: Garden City, MI; Pensacola, FL
Posts: 2,014
iTrader: (8)
Mentioned: 0 Post(s)
Send a message via Yahoo to Bronco351
Default

Nope, i checked the oil and it was at the correct level.
Bronco351 is offline   Reply With Quote
Old April 11th, 2008, 08:31 AM   #12
magna-007
Senior Member
 
magna-007's Avatar
 
Join Date: 09-13-06
Location: Portland, MI
Posts: 311
iTrader: (3)
Mentioned: 0 Post(s)
Default

Some motors just wont die, no matter what you do. This was at a buddies place last summer. This car was truly running on just water in the crank case and trans. We drove this car that weekend with just water in the trans. Blew a CV shaft and seal so had to keep putting water in every couple minutes. Hooked up the washer fluid bottle full of water and would squirt it right into the trans while driving.

http://www.youtube.com/watch?v=VuEV6YaBI04
http://www.youtube.com/watch?v=tvdc5ceskqM
magna-007 is offline   Reply With Quote
Reply
Great Lakes 4x4. The largest offroad forum in the Midwest > 4x4 Talk > Ford Tech
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:38 PM.


Powered by: vBulletin, Copyright 2000 - 2012, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2005 - 2012 Cracker Enterprises - Powered by Linux
vB Ad Management by =RedTyger=
Page generated in 0.13411 seconds with 36 queries