Great Lakes 4x4. The largest offroad forum in the Midwest - View Single Post - engine noise
Thread: engine noise
View Single Post
Old February 28th, 2006, 12:13 AM   #9
4x4inAllDay
Dodge Father-Ram Daughter
 
4x4inAllDay's Avatar
 
Join Date: 11-09-05
Location: Utica, Mi
Posts: 240
iTrader: (0)
Mentioned: 0 Post(s)
Send a message via AIM to 4x4inAllDay
Default

Quote:
Originally Posted by Haggar
Can you post up some more specifics?

How/Where did water get into the engine? Did you ever have the engine stall? Hard start?

I can tell you a past experience from the mounds.. stalled the engine in deep water. Was hard to restart, as the exhaust was filled with water.

No water got into the oil, but the hard starting put a lot of fuel into the cylinders, which washed down, and got into the crankcase. The extra gas thinned the oil.. Drove just back to the lot and put it on the trailer. Changed the oil, circuilated it, let it sit, changed it again(including the filter twice)

After that, it was like you mentioned.. no oil pressure at idle, noise from up top, and burning oil..

The oil thinned out due to the gas, and just ate up the bearings and the valve seals.

what kinda engine?



i never turned it off in the water... not till after i got it out... never stalled... i dont all know where the water came in but the oil definitly came out chocolate milk color




what did u do? total rebuild?
4x4inAllDay is offline   Reply With Quote
 
Page generated in 0.06072 seconds with 20 queries