Great Lakes 4x4. The largest offroad forum in the Midwest - View Single Post - 89 ranger getting too much fuel
View Single Post
Old January 6th, 2014, 10:36 AM   #1
rockstarryan211
Newbie
 
rockstarryan211's Avatar
 
Join Date: 06-08-13
Location: rockwood, mi
Posts: 19
iTrader: (0)
Mentioned: 0 Post(s)
Default 89 ranger getting too much fuel

I have an 89 ranger XLT 4x4 ext. cab.

whats been done to it...

-rebuilt 2.9l engine (less than 1000 miles on it as we speak)
-rebuilt A4LD automatic transmission (2x...1st rebuild was done wrong)

-new MAP sensor
-new TP sensor
-new o2 sensor
-new coolant temp sensor
-new plugs
-new wires
-new coil
-new fuel rail
-new fuel pressure regulator
-new fuel injectors
-new fuel pump
-new fuel filter
-new air filter
-new muffler
-new radiator/trans cooler
-new power steering pump
-new vacuum lines
-new everything down to each axle

im sure im forgetting something...

anyways... truck gets like 6 mpg... hard starting...blows black smoke like a diesel after started...dies if driven for more than like 15 continuous minutes then almost refuses to start back up...

someone who owned it before me decided to cut the main wiring harness and use butt connectors to put it back together.

I have started to solder and shrink tube all the wires back together while looking for a good used 2.9 automatic wiring harness.

I pulled the codes on it and it came up as low voltage to something..i cant remember what.

if you or someone you know has a non-molested 2.9 wiring harness in the southeastern Michigan area please let me know asap.

(idk if the wiring harnesses are different but the truck is an automatic, push button 4x4, power windows, power locks)

I basically want to plug in and go...

but anyways if you have any other ideas or things to check please message me or text me. thanks. Ryan. 734-717-9247. thanks again.
rockstarryan211 is offline   Reply With Quote
 
Page generated in 0.07545 seconds with 20 queries