Great Lakes 4x4. The largest offroad forum in the Midwest - View Single Post - WhiteRhino's Latest Mods
View Single Post
Old September 11th, 2013, 11:42 PM   #834
I'm not old, honest...
whiterhino's Avatar
Join Date: 03-07-06
Location: Davisburg MI
Posts: 24,828
iTrader: (23)
Mentioned: 78 Post(s)

Lots of progress tonight thanks to kb8ymf, offroadian & johnnyj. Items accomplished.
Fill rear diff with fluid.
Grease & install rear driveshaft
Install shifter & hook up shifter cable.
Install tailgate.
Mount blingy licence plate holder & plate to tailgate.
Install passenger seat & harness.
Install second battery & wire up winch.
Install rocker guards.
Install windshield.
Install windshield hoop.
Tune new shock with additional oil.
Install gas tank cap bezel.

We lifted it off the ground with the hoist & started the engine and verified the shifter and brakes work. Now I need to charge the shocks and it can be driven.

It looks like I will need to remake one of my windshield hoop to cage tie in's, it just doesn't line up quite right. We also had a minor setback where my brake lights & turn signals are acting up. With some research, it seems that it might be the wiring harness connector (OEM) or possibly my turn signal switch is malfunctioning. So, that's going to create some aggravation.

Sitting at ride height

So, the big ticket items remaining.
Charge shocks.
Figure out turn signal/brake lights.
Make new hoop tie in.
Wire inside winch controls, CB & HAM radios.
Install rear seat. (for the dog)
Install soft top.
Build front wheel wells.
Install windshield squirter bottle/pump.

Let's roll.
GLFWDA member since 1979.
Member Southern Michigan Rock Crawlers.
whiterhino is offline   Reply With Quote
Page generated in 0.06959 seconds with 21 queries