Great Lakes 4x4. The largest offroad forum in the Midwest - View Single Post - AC Crompressor/Mounting bracket off of 2000 XJ - GONE
View Single Post
Old May 15th, 2013, 02:47 PM   #1
Squishy
Needs More Cowbell
 
Squishy's Avatar
 
Join Date: 07-07-07
Location: Pontiac, MI
Posts: 630
iTrader: (2)
Mentioned: 0 Post(s)
Send a message via AIM to Squishy
Default AC Crompressor/Mounting bracket off of 2000 XJ - GONE

I swapped the AC compressor and it's mounting bracket off of my Cherokee, so the old ones are up for grabs.

The AC compressor hasn't been used in a long time, my XJ has an evaporator leak and I'm just not going to fix it. I did try to charge the system 2 years ago and the compressor did work as long as the system had pressure (Like 5 minutes), but I don't know if it is any good or not, that's why it's free. The pulley spins very easily, could still at least be used to replace a bad one to keep the same belt.

The bracket would need new bearings for the pulley on it, before it is useable. It spins, but it makes an awful lot of noise, it defiantly needs to be repaired before it's installed.


I live in White Lake, 48383, often in Waterford, 48329, and work in Rochester Hills, 48309. If I have to deliver this, I'm charging for gas. You can pick it up for free. Message me here or e-mail at Radioative003@gmail.com if you'd like them.

Last edited by Squishy; August 1st, 2013 at 12:37 AM. Reason: Item is gone.
Squishy is offline  
 
Page generated in 0.06997 seconds with 20 queries