Great Lakes 4x4. The largest offroad forum in the Midwest - View Single Post - 03 Sierra 5.3 Not Charging
View Single Post
Old January 28th, 2013, 12:09 PM   #1
Flexin' XJ
Senior Member
 
Flexin' XJ's Avatar
 
Join Date: 02-04-07
Location: Holt, MI
Posts: 4,459
iTrader: (19)
Mentioned: 0 Post(s)
Default 03 Sierra 5.3 Not Charging

My headlights have been dimming for a while when at a low RPM. Figured the alternator was on its way out but was always charging. I replaced the battery in September of 2011.

Sunday on my way into work my "Battery Not Charging" message was being displayed on the DIC. Figured the alternator finally crapped out. When I left work, it seemed fine. No message. I left for work this morning and as soon as I got on the road the headlights went way dim and the battery light came on and the message appeared again. The gauge showed between 9 and 14volts. I had to keep putting the truck in neutral and rev it to get the battery voltage back up for a short while.

Got to work and ordered an alternator. Put it in and same problem. Checked battery connections again and found the negative terminal was stripped and kinda loose. Got the parts store to warranty it and I have a new battery. Still not charging.

If I test the alternator with a DVOM, it has about 11.9v output at the battery. The same if I touch the output terminal at the alternator and the alternator case.

Seems like the computer isn't telling the alternator to charge. Any ideas? Bad PCM? Anybody have a wiring schematic for the charging system? I can't view photobucket at work.

Thanks.

Notes: Truck not charging. New alternator and battery today. Fusible link good. 11.9v at alternator. PCM not telling it to charge? Have battery power at DLC.

Last edited by Flexin' XJ; January 28th, 2013 at 01:03 PM.
Flexin' XJ is offline   Reply With Quote
 
Page generated in 0.11390 seconds with 20 queries