Great Lakes 4x4. The largest offroad forum in the Midwest - View Single Post - Kyle M. Ranger Truggy, rebuilt again - Revision 4
View Single Post
Old December 5th, 2010, 03:43 PM   #105
Kyle M.
MetroFab Customs
Kyle M.'s Avatar
Join Date: 10-24-10
Location: Howard City, MI
Posts: 9,244
iTrader: (20)
Mentioned: 53 Post(s)

Alright, decided to put my time to some use today. Did it write up style since I had the camera out with me...

Swapped out my tail lights today for some euros I had laying around. I used them before but the always fogged up and looked like ass so I decided to tint them, maybe they will look better if you can't see the ass.

So here are my original tails, then see my temp fix to get home. Zip ties FTW

and their replacements

cleaned them up with some wax and grease remover to prepare them for this

after 2 coats

a little dry time, and now installed, pure pimp

And I also had another problem yesterday, I have(had) a super ghetto fabed CAI on my truck to miss my shock hoop. Any way, I epoxied a cone filter to the MAF and it worked fine until yesterday when sometime the filter fell off. My truck started idling funny went and took a look and the filter was gone.

SO I dug up the other filter I had and decided to make it attach to my MAF a little less ghetto, here is how I did it.

I decided to cut the flange off the MAF, it looked like that if I took that off the filter could clamp right to it. So out came the cutting wheel and I went to town

then I cleaned it up a little

Filter mounted

mounted on the truck, finished

I am happy with it, took me 5 min to do and cost me nothing. Keep in mind this is a temp setup untill I get a different intake.
Kyle M. is offline   Reply With Quote
Page generated in 0.10176 seconds with 21 queries