Great Lakes 4x4. The largest offroad forum in the Midwest - View Single Post - A/C System Vacuuming/filling
View Single Post
Old July 22nd, 2010, 12:50 AM   #4
wave_crusher
I'll Direc your TV
 
wave_crusher's Avatar
 
Join Date: 01-20-09
Location: Big Rapids, MI
Posts: 5,278
iTrader: (22)
Mentioned: 1 Post(s)
Default

Quote:
Originally Posted by Jeeperz Creeperz View Post
Depends on whether the clutch is squealing because the compressor is locked up or because the pulley bearings are bad (or a combination of both).

You'll need to determine if you have a charge in the system or not and proceed accordingly. Unless you're familiar with the process, the best results for reclaim/repair/evacuation/recharge would be obtained by taking it to a shop that has the proper equipment.
I've tried charging it before, with a can of the artic freeze stuff, with the gague on it. It's never fully out, there's always at least 10-15psi in it or so. I've charged it to where it should be (about 50-55 psi, depending on ambient air temp) but the air never gets cold. An it's squeeing because the bearing are bad, the compressor will not be on and it will squeel, it sounds exactally like a bad clutch, when the compressor is on it wont make any noise, then when it shuts off, it will grind/squeel

Quote:
Originally Posted by MidMichxj View Post
Check with Peter @ Eastwood Autoworks in your area.
Thanks for the refferal, i'll have to stop by. I've seen his ads in the alpena news, never thought much about it
wave_crusher is offline   Reply With Quote
 
Page generated in 0.08542 seconds with 20 queries