Great Lakes 4x4. The largest offroad forum in the Midwest - View Single Post - 1966 Chevrolet C-10 (TourMater)
View Single Post
Old November 16th, 2009, 11:03 AM   #47
ScOoTeR
hoo dat. wat.
 
ScOoTeR's Avatar
 
Join Date: 11-09-05
Location: Howell
Posts: 21,579
iTrader: (36)
Mentioned: 10 Post(s)
Default

Well, well, well...

I found the original builder of the engine...
http://www.greatlakes4x4.com/showthr...&highlight=377

Quote:
Originally Posted by Brads01ws6
the block and heads came from a camaro block was cleaned and honed, heads were checked and ported, crank was cut to 350 journals, and machined to clear the pistons, rods are also reconditioned 400 rods cut to 350 journal, motor has not been fired since it assembly. was gonna use it for firgure 8 racing in a 76 monte carlo but dont know if ill have the money to build the rest of the car so putting the whole project on hold until the money situation gets a little better.
I would seriously reconsider EVER buying something from Brads01ws6

Since SBC's come from anywhere and go anywhere, the camaro part isn't misleading, however,
* the block is from a 1970 C10 (according to the stamping)
* the heads are these:
1970-80 333882 350,400 1.94 1.5 76
E164 = Cast on May 16th, 1974

The crank is a 400 casting...however - I'm not sure on it never being fired...




So I found the root of my engine problem. Brads01ws6.
I can't do anything about it, however, I can let people know that anything you sell may not be 100% factual.

__________________
@clarkstoncracker
ScOoTeR is offline   Reply With Quote
 
Page generated in 0.07603 seconds with 20 queries