Great Lakes 4x4. The largest offroad forum in the Midwest - View Single Post - 95 1500 5.9 Ram Timing issue.
View Single Post
Old June 25th, 2009, 12:25 AM   #1
Freak
Wheelin the HD
 
Freak's Avatar
 
Join Date: 01-27-07
Location: Portland, TX
Posts: 7,227
iTrader: (14)
Mentioned: 0 Post(s)
Send a message via MSN to Freak Send a message via Yahoo to Freak
Default 95 1500 5.9 Ram Timing issue.

My 95 Ram 1500 4x4 5.9 360 V8 acts like it is stalling while at 1/2-3/4 throttle, typically when I move my foot a little, typically after a few miles driving at full temperature, but its not consistent, and I cant cause it when I have time to look at it. Some times it back fires, some times it just falls on its face then picks right back up, sometimes it takes a bit of cranking to start, some times it starts right away. Its also developing a rough idle and stalling condition when it idles for a minute in park or neutral. Exhaust smokes white when cold but its not using coolant, burns about 2 quarts of oil every few thousand miles exhaust pipe has a nice sooty black, as it always has been.
Problem started occurring after my trip to Silver Lake last weekend.

So, I am leaning to the Crank Sensor, might explain the white smoke as not enough advance and unburnt fuel, and not burning hot enough would also explain the carbon build up, and the occasional miss, also had a tune up about 10K miles ago.

Last edited by Freak; June 26th, 2009 at 05:58 PM.
Freak is offline   Reply With Quote
 
Page generated in 0.05071 seconds with 20 queries